Closed Bug 1666776 Opened 1 year ago Closed 1 year ago

Start print when Enter is pressed when print preview select controls are focused

Categories

(Toolkit :: Printing, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
83 Branch
Tracking Status
firefox83 --- verified

People

(Reporter: jwatt, Assigned: mstriemer)

References

Details

(Whiteboard: [print2020_v82][old-ui-])

Attachments

(1 file)

This has irked me, and since I've just noticed a SUMO issue about this I thought I better file it: https://support.mozilla.org/en-US/questions/1302466

This is annoying for people who only use a keyboard. From what I can tell you basically have to tab through everything until you arrive at the Print button.

Yeah, let me bump this to P1 to get it on the frontend team's radar and see what they think.

Priority: P2 → P1
Whiteboard: [print2020_v83][old-ui-] → [print2020_v82][old-ui-]
Flags: needinfo?(mstriemer)
Flags: needinfo?(bwinton)

So, Mark and I have chatted about this, and want to get a little more information from our friendly a11y folks before making this change. I feel like putting focus on the very last thing on the page isn't the right answer here, since <enter> submits the form if you're on most of the other controls, and because it seems like it would be kinda confusing.

https://developer.mozilla.org/en-US/docs/Web/Accessibility/ARIA/Roles/dialog_role says that "it could be the first field in the form", which is what we're currently doing.

So, I think we're probably going to try and change it so that <enter> always submits the form, but I'll let Mark confirm that.
(And yeah, getting it into 82 would be nice.)

Flags: needinfo?(bwinton)

Let's punt this to v83 then? I assume since Jamie hasn't mentioned this as an issue it isn't critical for a11y.

Flags: needinfo?(jteh)
Whiteboard: [print2020_v82][old-ui-] → [print2020_v83][old-ui-]

I discussed this with marcoz and yzen in #accessibility on Slack and they were okay with us moving the focus to the Print button instead since you can use F6/Shift+F6 to between the address bar, preview browser and top of the settings browser.

I'll take a look at getting this done today so we can include it in v82.

Assignee: nobody → mstriemer
Status: NEW → ASSIGNED
Flags: needinfo?(mstriemer)
Whiteboard: [print2020_v83][old-ui-] → [print2020_v82][old-ui-]

(In reply to Mark Striemer [:mstriemer] from comment #5)

I discussed this with marcoz and yzen in #accessibility on Slack and they were okay with us moving the focus to the Print button instead since you can use F6/Shift+F6 to between the address bar, preview browser and top of the settings browser.

While it's true that you can use f6 or shift+f6 to get to the settings, it's definitely not delightful or efficient and potentially quite confusing for less experienced users. This would probably be acceptable in a world where users rarely touch the settings (which is what I think Marco and Yura were thinking), but since PDF printing is done by changing the printer, I don't think this is so true these days. I'd really prefer that we keep initial focus on the printer picker and override enter to submit the form here (but ideally only if the picker isn't expanded, which... I hope we can detect that?).

(As a side note, why does enter on a select do nothing in a form anyway? That doesn't seem useful to me.)

That said, I do understand this is potentially time sensitive, so I guess I can live with this for 82 if the other patch is problematic/harder to write and we want this fixed in 82.

Flags: needinfo?(jteh)
Attachment #9178589 - Attachment description: Bug 1666776 - Focus Print button on tab-modal print UI load r?jamie,emalysz,gijs → Bug 1666776 - Start print with Enter when select is focused r?jamie,emalysz,gijs
Summary: Focus the "Print" button in the new UI as soon as it opens → Start print when Enter is pressed when print preview select controls are focused
Duplicate of this bug: 1669182
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7b5fa53e519c
Start print with Enter when select is focused r=Jamie,emalysz
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch
Flags: qe-verify+

Confirming that printing is now started when Enter is pressed across platform, using Fx 83.0b2.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.