Closed Bug 1667025 Opened 9 months ago Closed 9 months ago

Options in End-to-End Encryption in Manage Identities are not saved

Categories

(Thunderbird :: Account Manager, defect)

defect

Tracking

(thunderbird_esr78+ fixed, thunderbird82+ fixed)

RESOLVED FIXED
83 Branch
Tracking Status
thunderbird_esr78 + fixed
thunderbird82 + fixed

People

(Reporter: martin, Assigned: khushil324)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.102 Safari/537.36

Steps to reproduce:

Opened any of my alternate identities of an account in Account Settings -> Manage Identities and there under End-to-End Encryption I changed some settings like "Add my digital signature by default" and "Preferred encryption technology". Then clicked "Ok" for saving the changes. I get back to the list of identities.

Actual results:

The changes are not saved.

Expected results:

Saved changes. ;-)

Confirmed. Khushil, please take a look.

Assignee: nobody → khushil324
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → ASSIGNED
Comment on attachment 9178978 [details] [diff] [review]
Bug-1667025_e2e-manage-indetities-not-saving-0.patch

Review of attachment 9178978 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, I assume this never worked in 78.
Attachment #9178978 - Flags: review?(mkmelin+mozilla) → review+
Target Milestone: --- → 83 Branch

Yes, we need beta uplift as well as ESR uplift.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/a85aeb24984a
Fix options in End-to-End Encryption in Manage Identities are not saved. r=mkmelin DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED

Comment on attachment 9178978 [details] [diff] [review]
Bug-1667025_e2e-manage-indetities-not-saving-0.patch

[Approval Request Comment]
Regression caused by (bug #): Bug 1610445
User impact if declined: Encryption setting in manage identities will not be saved.
Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky): Low

Attachment #9178978 - Flags: approval-comm-esr78?
Attachment #9178978 - Flags: approval-comm-beta?

Comment on attachment 9178978 [details] [diff] [review]
Bug-1667025_e2e-manage-indetities-not-saving-0.patch

[Triage Comment]
Approved for esr78
Approved for beta

Attachment #9178978 - Flags: approval-comm-esr78?
Attachment #9178978 - Flags: approval-comm-esr78+
Attachment #9178978 - Flags: approval-comm-beta?
Attachment #9178978 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.