Closed Bug 1667141 Opened 2 months ago Closed 1 month ago

T-Online IMAP Quota

Categories

(Thunderbird :: Mail Window Front End, defect)

defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: maniac-mega-vision, Unassigned)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

View t-online inbox

Actual results:

red 100% Quota Message at bottom

Expected results:

Do not show 100%

Component: Untriaged → Mail Window Front End
Flags: needinfo?(richard.marti)

My IMAP servers show only one quota, the STORAGE. It seems that the quota display in the status bar checks the last showed and here, for this purpose, wrong quota (for what is the LEVEL quota?).

Maybe Gene can help, he's our IMAP specialist.

Flags: needinfo?(richard.marti) → needinfo?(gds)

No idea what a "Level" quota is. I would be curious to be sure the imap log reports the 4 quota items correctly as shown in the attachments.

Reporter maniac, please attach an IMAP:5 log showing at least the getquotaroot response from the server where "Level" occurs in the log. See https://wiki.mozilla.org/MailNews:Logging

You might also ask on this forum about what a "Level" quota is: https://telekomhilft.telekom.de/t5/tag/Quota%20exceeded/tg-p/board-id/313?
My best guess is the number of users on the account, maybe you have 3 users with a maximum of 3?

It's also discussed here in German: https://forum.chip.de/discussion/824179/t-online-und-der-mailbox-is-over-level-quota-fehler but not sure if this is the same "level" as tb is reporting.

If this is a common problem we might consider limiting tb's quota display to the first 3 items shown above: storage, messages, and mailboxes.

Flags: needinfo?(gds)

I translated the forum page and it appears that level is how deep your folders can be. So 3 might be:

Inbox
  From-Jim
    From-Jim-to-Joe

Maniac, I assume reducing your levels to 2 would be unacceptable to clear the error?

You might also change in the config editor these items to prevent the quota from appearing on the main window:

mail.quota.mainwindow_threshold.critical = 101
mail.quota.mainwindow_threshold.show = 101
mail.quota.mainwindow_threshold.warning = 101

A restart of TB after changing these is probably required. Let me know if this works. If it does, no need to produce the imap log.
Thanks.

There has clearly something changed in TB 78.
As second Attatchment shows (same E-Mail Account at same Time) this Problem is not present in 68.x

(In reply to maniac-mega-vision from comment #6)

There has clearly something changed in TB 78.
As second Attatchment shows (same E-Mail Account at same Time) this Problem is not present in 68.x

Yes, its a new feature of 78 to show ALL the quota items reported by the server and not just the storage. The bar-graph display is also improved. But I didn't anticipate a quota item as reported by your ISP like level of 3 that is very restrictive and easy to reach so it will make the bar-graph on the main page display continuously. Does it not show the red bar-graph on the main screen if you do what I suggest in comment 5?

P/S: I'm curious of what your current folder level count is. Is the quota screen correct and your level is 3? What happens if you try to create a folder tree with more than 3 levels? Will T-Online let you create more than 3 levels?

Does it not show the red bar-graph on the main screen if you do what I suggest in comment 5?

No. (Closing TB not necessary) This is a global setting for all Accounts, right?

Will T-Online let you create more than 3 levels?

No. Wow. (I got to that limit once but forgot about it)

(In reply to maniac-mega-vision from comment #8)

Does it not show the red bar-graph on the main screen if you do what I suggest in comment 5?

No. (Closing TB not necessary) This is a global setting for all Accounts, right?

Yes, it's not account specific and applies to all accounts and quota items. So I think you are saying the problem is solved?

Duplicate of this bug: 1670584
Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → INVALID

This is clearly a bug in this "new" function.
A fix will be that "LEVEL"-of-folders is misinterpreted by TB as UserQuota at all and throw a massage.
Or why cahange a running system? Simply roll back to TB 68 in this.

Comment 5 isnt a workaround because i am not the only one that is using t-online as IMAP and other IMAP-Accounts at the same time.

Blocks: 1671748

Reporter, m-m-v. I see your point. I've proposed a change that may resolve the issue you are seeing without having to revert the quota handling back to 68. See bug 1671748.

You need to log in before you can comment on or make changes to this bug.