Closed Bug 1667239 Opened 2 years ago Closed 2 years ago

Picture in picture button lacks expected text during Omnibus Foxfooding experiment

Categories

(Core :: Audio/Video: Playback, defect)

Firefox 81
x86_64
Linux
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: hellosct1, Unassigned)

References

Details

Attachments

(1 file)

Attached image picture0.jpg

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:81.0) Gecko/20100101 Firefox/81.0

Steps to reproduce:

on Ubuntu 20

Actual results:

Nothing.
file screenshot : picture0.jpg

Expected results:

The “Watch in Picture-in-Picture” button will be displayed on the right side of the video with text.

Blocks: 1666612

OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core

:hellosct, the image looks like it has the PiP button. Is the issue that the button doesn't show the text when hovered over? Does the button function if clicked?

Mike, can you help me place this in the appropriate component?

Flags: needinfo?(mconley)
Flags: needinfo?(hellosct1)

hi,

this is a ticket that is dependent on 1666612. The document lists a number of features that should work. The ticket shows that this is not the case.

Foxfooding: https://docs.google.com/document/d/1Hv3egcIlcbb1DiiG4dnyZFQkGSr4MJQ_L64UBXmzBSk/edit#

It's linked to the campaign Firefox Omnibus Foxfooding experiment

the test listed in the document is unique and it is not a duplicate ticket

Flags: needinfo?(hellosct1)

My STR based on information here and in bug 1667236.

  • Use the 'Treatment' profile listed in the Omnibus Foxfooding Experiment Doc
  • Visit youtube and play a video.
  • Observe the picture in picture button while not hovering it and hovering.

Actual result:
No text is shown in either case, as per attached screenshot.

Expected result:
Text should be shown while not hovering per the experiment doc. Further text should be shown while hovering.

Severity: -- → S4
Summary: description right side of the video with text → Picture in picture button lacks expected text during Omnibus Foxfooding experiment

Thanks for the report! The Foxfooding doc is missing some information and needs to be updated.

In the new design, the text for "Watch in Picture-in-Picture" only displays for the first time a user engages with the button. This is to help introduce users to the feature. After that you will only see the small circular icon that you see in the screenshot, no text is shown on hover.

Since this is the expected behaviour, I'm going to close this report as invalid.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(mconley)
Resolution: --- → INVALID

Hi Adam, the information was present in the document since the beginning under the "Notes" section for PiP testing.
"Notes:

  • After the button was clicked at least once only the PiP button will be displayed without the string and the description."

However, please let me know if you think it needs to be emphasized/described more in the document.

Thanks Paul, yep I realized after that the note is there. I updated it the other day to be a little bit more descriptive and added another screenshot.

You need to log in before you can comment on or make changes to this bug.