Closed Bug 1667360 Opened 1 year ago Closed 1 month ago

Youtube videos on Windows don't play anymore with RDD opus enabled with mingw-clang build

Categories

(Core :: Audio/Video: Playback, defect, P3)

78 Branch
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr78 --- wontfix
firefox-esr91 --- unaffected
firefox86 --- unaffected

People

(Reporter: gk, Unassigned)

References

(Blocks 1 open bug)

Details

We released Tor Browser 10 this week which is based on Firefox 78 ESR and since then a lot of users reported that Youtube videos on Windows don't play anymore. One only sees an error message: "An error occurred. Please try again later (Playback ID: $ID) Learn More"

This is not a Tor Browser-only issue, though, but happens with regular Firefox 78 ESR, too, as long as they are built with mingw-clang. I could not test nightly builds as I only get a white screen, so this is busted differently. The debug build did not have any useful info in the console as far as I could tell.

So folks saw in Tor Browser something like

  Media resource blob:https://www.youtube.com/754495fa-09d2-4478-8bfc-02b7d64d19a4 could not be decoded. watch
        This error message will be blank when privacy.resistFingerprinting = true.  If it is really necessary, please add it to the whitelist in MediaError::GetMessage: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - mozilla::MediaResult mozilla::RemoteAudioDecoderChild::InitIPDL(const mozilla::AudioInfo &, const CreateDecoderParams::OptionSet &): RemoteDecoderManager is not available. base.js:6004:19

in the browser console which might give a hint about what is going on.

Users reported that flipping media.rdd-opus.enabled back to false "solves" this problem.

Blocks: mingw-clang

Michael, have you seen this before? Do you know who should look at this?

Flags: needinfo?(mfroman)

Could this be related to Bug 1519608 (RDD Process causes hung process with mingw-clang build)?

We have seen that same failure (NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - mozilla::MediaResult mozilla::RemoteAudioDecoderChild::InitIPDL) on occasion, but never been able to track it down past either an RDD launch failure or a IPC setup failure. Unfortunately, I've been unable to repro the issue locally. See Bug 1661987 or Bug 1664441 for more details.

Since it appears to be process startup and/or IPC setup related, I think we need someone with more experience in those areas to investigate.

Flags: needinfo?(mfroman)

I've created bug 1667423 to track the mingw-clang nightlies being busted. I'll keep an eye on that and once it's fixed see if I can investigate this further.

Severity: -- → S3
Priority: -- → P3

(In reply to Bryce Seager van Dyk (:bryce) from comment #3)

I've created bug 1667423 to track the mingw-clang nightlies being busted. I'll keep an eye on that and once it's fixed see if I can investigate this further.

Thanks for both, really appreciated. One thing that could work, though, for this bug is grabbing an esr78 build based on mingw-clang. They come in debug and opt flavor and .pdb files are included in both.

Flags: needinfo?(bvandyk)

I can repro this on ESR but not on nightly.

  • media.rdd-opus.enabled to false prevents the issue.
  • MOZ_DISABLE_RDD_SANDBOX=1 env var prevents the issue.

So opus rdd is not working due to sandbox problems. I'm having trouble getting sandbox logs out the current binaries I'm debugging, will hold NI and see if I can get more info.

I think mingw builds have a 1 year expiry on mozilla-central. While mozregression won't work out of the box, I bet a custom mozregression script might. I think that's useful enough it's worth genning up so I'm going to give it a shot...

EDIT: I got the annoying API bits out of the way, but needed to move on to other things for now. Posting a WIP https://gist.github.com/tomrittervg/cfa1467833459faa276e1ab85ccdae7a

Is this still happening in 91?

(In reply to Marco Castelluccio [:marco] from comment #7)

Is this still happening in 91?

Good question. Richard/Matt can any of you check?

Flags: needinfo?(sysrqb)
Flags: needinfo?(richard)

This issue appears to be fixed in esr91 and esr91-based tor-browser ( you can also test the audio file playback here: https://opus-codec.org/examples/ if youtube is being persnickety )

Flags: needinfo?(richard)
Flags: needinfo?(bvandyk)

I suppose we can close it out then!

Status: NEW → RESOLVED
Closed: 1 month ago
Flags: needinfo?(sysrqb)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.