Closed Bug 1667931 Opened 2 months ago Closed 2 months ago

Installed default search engine using POST no longer works with single search terms

Categories

(Firefox :: Address Bar, defect, P2)

Firefox 82
defect

Tracking

()

VERIFIED FIXED
83 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox81 --- unaffected
firefox82 + fixed
firefox83 + verified
firefox84 --- verified

People

(Reporter: ke5trel, Assigned: mak)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

STR:

  1. Install Add custom search engine extension.
  2. Add a search engine:
    "DuckDuckPOST"
    https://duckduckgo.com/
    POST
    q={searchTerms}
  3. Make it the default search engine.
  4. Type "test" in location bar.

Expected:

test -- Search with DuckDuckPOST

Actual:

http://test/ -- Visit

Doesn't search for single terms but does for multiple terms separated by spaces.

Regression range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=c74ba13e5d6f51f0ad83f5cf61b6edd0d0b2b3cc&tochange=44801b6e7c7a2d333c287b926a7118356c396a2d

Regressed by Bug 1656302.

Severity: -- → S3
Priority: -- → P2

postData is optional out argument, Bug 1656302 removed the XPCShell Wrapper that was defining an empty object for it and then doing the conversion on the boundary. So now postData in some cases is undefined.
We should probably fix Bug 1626016, and add a test for this case.

Depends on: 1626016

Could we backout Bug 1656302 from 82, so we have some time to fix bug 1626016 in 83?
The regression is pretty bad since it means a default POST engine breaks the urlbar, while Bug 1656302 was just some console spew.

Flags: needinfo?(jdragojevic)
Duplicate of this bug: 1670701

[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]: POST search engines are broken in the urlbar.

We already built a 82 release candidate, and this bug is marked S3. I can back out and spin a new build, I guess, but that probably means the severity is set wrong.

I guess we should also back out for 83?

Flags: needinfo?(mak)
Flags: needinfo?(jdragojevic)

(In reply to Julien Cristau [:jcristau] from comment #5)

I guess we should also back out for 83?

Or not, since it looks like we're fixing bug 1626016 there instead.

(In reply to Julien Cristau [:jcristau] from comment #5)

We already built a 82 release candidate, and this bug is marked S3. I can back out and spin a new build, I guess, but that probably means the severity is set wrong.

Yes, I think it's an S2. POST engines are not so common as GET, but still users having them as default get a bad urlbar search experience.

I guess we should also back out for 83?

I am fixing 83 in bug 1626016, so it doesn't need a backout.

Severity: S3 → S2
Flags: needinfo?(mak)
Assignee: nobody → mak
Status: NEW → ASSIGNED

Ok, the bug is fixed by dependencies, but I still want to add an explicit urlbar test here, since Bug 1626016 added a URIFixup API test.

Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/159d9266d98e
Add a urlbar test searching a single word with a default POST engine. r=adw
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch

I have managed to reproduce the issue in Fx83.0a1 buildID: 20200928212824.
The issue is verified fixed using the latest nightly build Fx84.0a1 and beta Fx83.0b2 on Windows 10 and Ubuntu 18.04. Using the provided steps, the correct text is now shown for the custom POST search engine, in this case "Search with DuckDuckPOST".

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.