Closed Bug 1668592 Opened 2 years ago Closed 2 years ago

Crash in [@ nsPipeInputStream::ReadSegments]

Categories

(Core :: Networking, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1673186

People

(Reporter: sefeng, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

Crash report: https://crash-stats.mozilla.org/report/index/be8ba891-4543-4623-a331-8df2a0200929

Reason: SIGSEGV /SEGV_MAPERR
MOZ_CRASH Reason: MOZ_DIAGNOSTIC_ASSERT(!mReadState.mActiveRead)

Top 10 frames of crashing thread:

0 libxul.so nsPipeInputStream::ReadSegments xpcom/io/nsPipe3.cpp:1314
1 libxul.so nsInputStreamPump::PeekStream netwerk/base/nsInputStreamPump.cpp:104
2 libxul.so nsBaseChannel::OnStartRequest netwerk/base/nsBaseChannel.cpp:826
3 libxul.so nsInputStreamPump::OnInputStreamReady netwerk/base/nsInputStreamPump.cpp:390
4 libxul.so nsInputStreamReadyEvent::Run xpcom/io/nsStreamUtils.cpp:94
5 libxul.so mozilla::TaskController::DoExecuteNextTaskOnlyMainThreadInternal xpcom/threads/TaskController.cpp:514
6 libxul.so nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1234
7 libxul.so mozilla::ipc::MessagePump::Run ipc/glue/MessagePump.cpp:87
8 libxul.so MessageLoop::Run ipc/chromium/src/base/message_loop.cc:309
9 libxul.so nsBaseAppShell::Run widget/nsBaseAppShell.cpp:137

I only see one crash from this signature, however, this seems like a valid crash.

Hi Valentin, any idea what might be going on here?

Component: XPCOM → Networking
Flags: needinfo?(valentin.gosu)
Flags: needinfo?(mconley)
Keywords: regression
Regressed by: 1672517
See Also: → 1579683
Has Regression Range: --- → yes

Seems the same as bug 1673186.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(valentin.gosu)
Resolution: --- → FIXED
See Also: → 1673186
Flags: needinfo?(mconley)
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1673186
No longer regressed by: 1672517
See Also: 1579683, 1673186
You need to log in before you can comment on or make changes to this bug.