Closed Bug 1672517 Opened 6 months ago Closed 6 months ago

Enable the about:home startup cache on Nightly (only) by default

Categories

(Firefox :: New Tab Page, task)

task

Tracking

()

RESOLVED FIXED
84 Branch
Tracking Status
firefox84 --- fixed

People

(Reporter: mconley, Assigned: mconley)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

Attachments

(1 file)

As it says on the tin. This will hold on Nightly while we assess its behaviour in the wild.

Assignee: nobody → mconley
Status: NEW → ASSIGNED
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9dfa75f6ec73
Enable the about:home startup cache by default on Nightly only. r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch

Hi Mike. Seems like intermittent Bug 1579683 was caused by this bug. Job retriggers from here revealed 9dfa75f6ec73 to be the start of the intermittent. I made a local backout and pushed to try, which confirmed my findings.

Flags: needinfo?(mconley)

(In reply to Pulsebot from comment #2)

Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9dfa75f6ec73
Enable the about:home startup cache by default on Nightly only. r=Gijs

== Change summary for alert #27509 (as of Wed, 04 Nov 2020 12:24:15 GMT) ==

Improvements:

Ratio Suite Test Platform Options Absolute values (old vs new)
56% about_newtab_with_snippets windows10-64-shippable-qr e10s stylo webrender 67.83 -> 29.89

For up to date results, see: https://treeherder.mozilla.org/perfherder/alerts?id=27509

Flags: needinfo?(mconley)

refreshing needinfo.

Flags: needinfo?(mconley)

Thanks, sorry for the delay, taking bug 1579683.

Flags: needinfo?(mconley)
You need to log in before you can comment on or make changes to this bug.