Closed Bug 1668762 Opened 1 year ago Closed 1 year ago

[PI-819] Images are not displayed on the print preview before printing at least once using the old UI on Windows

Categories

(Core :: Print Preview, defect, P2)

Desktop
Windows
defect

Tracking

()

RESOLVED DUPLICATE of bug 1669187

People

(Reporter: ppop, Unassigned)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [print2020_v82] [old-ui+])

Attachments

(1 file)

Attached image print_images.gif

[Affected versions]:

  • Firefox Beta 82.0b5, Build ID 20200929175845

[Affected platforms]:

  • Windows 10 x64

[Prerequisites]:

  • Have the "print.tab_modal.enabled" pref set as "false".

[Steps to reproduce]:

  1. Open the browser with the profile from prerequisites and navigate to the about:newtab page.
  2. Click the hamburger menu button and click the "Print..." option.
  3. Click the "Page Setup..." button and check the "Print Background (colors & images)" checkbox.
  4. Observe the behavior.

[Expected result]:

  • The print preview is refreshed and the images are displayed.

[Actual result]:

  • The print preview is refreshed and no images appear on the page.

[Regression]:

[Notes]:

  • This issue is not reproducible using the new UI.
  • Workaround: The print preview correctly displays images after printing to PDF at least once.
  • This issue is not reproducible on macOS and linux.
  • Attached a screen recording of the issue:

Regression for the old UI. Tentatively tracking this for 82.

Regressed by: 1665064
Whiteboard: [print2020_v82] [old-ui+]

ni? emilio based on the regressing bug, but I'm setting this at P2.

Component: Printing → Print Preview
Flags: needinfo?(emilio)
Priority: -- → P2
Product: Toolkit → Core

Suspiciously similar to bug 1668621, even if the regressing commit is different. The patch for that bug may fix this one too.

Yeah, I think this is just bug 1668621. I think my patch just uncovered the settings difference because we used not to honor them.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(emilio)
Resolution: --- → DUPLICATE
Duplicate of bug: 1668621

The patch for bug 1669187 fixes this, at least to the extent we can without taking on too much risk.

Duplicate of bug: 1669187
You need to log in before you can comment on or make changes to this bug.