Closed Bug 1669147 Opened 8 months ago Closed 8 months ago

URL in Readme.txt not pointing to latest Thunderbird release; still pointing to v68.12.1instead of v78.3.1

Categories

(Thunderbird :: Build Config, defect, P3)

Tracking

(thunderbird_esr68 fixed, thunderbird_esr78 unaffected)

RESOLVED FIXED
Thunderbird 68.0
Tracking Status
thunderbird_esr68 --- fixed
thunderbird_esr78 --- unaffected

People

(Reporter: vinswasre123, Assigned: rjl)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.121 Safari/537.36

Steps to reproduce:

Refer Bug 1265936 same issue

Using web browser visited here: https://download.mozilla.org/?product=thunderbird-latest&os=win&lang=en-US

Actual results:

Yet when attempting to visit such a URL (e.g., Windows version in English):
https://download.mozilla.org/?product=thunderbird-latest&os=win&lang=en-US

we are still redirected to 68. That is, the URL becomes:
https://download-installer.cdn.mozilla.net/pub/thunderbird/releases/68.12.1/win32/en-US/Thunderbird%20Setup%2068.12.1.exe

Expected results:

As documented here:
http://ftp.mozilla.org/pub/thunderbird/releases/latest/README.txt

the URL of the format:
https://download.mozilla.org/?product=thunderbird-latest&os=<OS>&lang=<LANG>

SHOULD point to the latest release, which currently appears to be 78 as indicated here:
https://www.mozilla.org/en-US/thunderbird/notes/

must point automatically to (currently )

https://download-installer.cdn.mozilla.net/pub/thunderbird/releases/78.3.1/win32/en-US/Thunderbird%20Setup%2078.3.1.exe

Flags: needinfo?(rail)
Flags: needinfo?(kmoir)
Component: Installer → Build Config
Flags: needinfo?(rob)
Flags: needinfo?(rail)
Flags: needinfo?(kmoir)

We haven't yet upgraded users to 78. "latest" is the latest we upgraded people to IIRC.

It's because we released 68.12.1 and did not disable the bouncer-update job prior to doing so.
78.3.2 was released in the last couple of days, so the bouncer is pointing to that version now. As long as there are no more 68 releases we'll be good until Thunderbird 90.
I will however make the necessary changes on c-esr68 just on the off chance we have to release 68.12.2, and I will add this to the notes I have for esr switchover so we will hopefully not make this error again.

Assignee: nobody → rob
Flags: needinfo?(rob)
Priority: -- → P3

This is for documentation purposes as there are no plans for further
releases based on esr68.
This is a recurring problem every release. The new release (eg 78.0) comes
out and is followed by a release from the previous version. The download
bouncer's "latest" aliases are overwritten with the old version, which is
not what we want.
This bug is referred to in the notes for esr78 launch so that it is not
missed for Thunderbird 90.

Status: UNCONFIRMED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 68.0
You need to log in before you can comment on or make changes to this bug.