Closed Bug 1669483 Opened 6 months ago Closed 5 months ago

Notify me about new features from What’s New can’t be selected using Tab key

Categories

(Firefox :: Messaging System, defect, P1)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
84 Branch
Iteration:
84.1 - Oct 19 - Nov 01
Tracking Status
firefox-esr78 --- wontfix
firefox81 --- wontfix
firefox82 --- wontfix
firefox83 --- wontfix
firefox84 --- verified

People

(Reporter: atrif, Assigned: emcminn)

References

(Regression)

Details

(Keywords: access, regression, Whiteboard: [access-s2])

Attachments

(2 files)

Attached image what's_new.gif

Affected versions

  • 83.0a1 (20201006041051)
  • 82.0b7 (20201002191150)
  • 81.0.1 (20200930150533)

Affected platforms

  • Windows 10x64
  • macOS 11
  • Ubuntu 18.04

Steps to reproduce

  1. Open Firefox and What’s New panel from the hamburger menu.
  2. Use the tab key to navigate between options.

Expected result

  • All options can be selected.

Actual result

  • Notify me about new features cannot be selected using keyboard navigation.

Regression range

Notes

  • Attached a screen recording.

Suggested Severity: S3

Has Regression Range: --- → yes
Has STR: --- → yes
Keywords: access

Access-s2 because this feature is now completely inaccessible to keyboard users (including most screen reader users).

Whiteboard: [access-s2]
Assignee: nobody → andrei.br92
Severity: -- → S3
Iteration: --- → 84.1 - Oct 19 - Nov 01
Priority: -- → P1
Target Milestone: --- → 84 Branch

We have a keyboard shortcut that can be used to toggle the feature off and on. Is that sufficient?

Flags: needinfo?(jteh)

I don't think so because it's not discoverable to screen reader users. If they can't focus the option, they'll never know it exists and thus never learn it has a shortcut.

FWIW, the reason this regressed is that you removed the <toolbarbutton> wrapping the <checkbox>. PanelMultiView considers toolbarbutton as a candidate for keyboard navigation, but not checkbox:
https://searchfox.org/mozilla-central/rev/61728de8273c04fe2417c475fc0637e8b79210d7/browser/components/customizableui/PanelMultiView.jsm#1564

Flags: needinfo?(jteh)

Can you please take this one? We need to revert the layout changes from bug 1599138 to get the <toolbarbutton> back.

Flags: needinfo?(emcminn)

Hi, yep, I can take this!

Flags: needinfo?(emcminn)
Assignee: andrei.br92 → emcminn

(In reply to Andrei Oprea [:andreio] from comment #4)

Can you please take this one? We need to revert the layout changes from bug 1599138 to get the <toolbarbutton> back.

Alternatively, you could tweak PanelMultiView to allow checkbox as a candidate for keyboard navigation. It already looks for a bunch of other elements, so this probably isn't unreasonable. That would be a one line patch plus a test in the right place.

Although you'd need to make sure it doesn't choke in the case that there is a checkbox inside of a toolbarbutton. I don't know if that happens anywhere in our code base.

(In reply to James Teh [:Jamie] from comment #6)

(In reply to Andrei Oprea [:andreio] from comment #4)

Can you please take this one? We need to revert the layout changes from bug 1599138 to get the <toolbarbutton> back.

Alternatively, you could tweak PanelMultiView to allow checkbox as a candidate for keyboard navigation. It already looks for a bunch of other elements, so this probably isn't unreasonable. That would be a one line patch plus a test in the right place.

That sounds like a great solution; I'm going to work on this today so I'll give it a shot. We made some pretty deep changes to the panel when we implemented that checkbox iirc, so it would be nice not to have to revert them all...

Attachment #9183195 - Attachment description: Bug 1669483 - Restore keyboard navigation to WhatsNewPanel → Bug 1669483 - Restore keyboard navigation to WhatsNewPanel footer
Pushed by emcminn@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a127fb101679
Restore keyboard navigation to WhatsNewPanel footer r=Jamie,andreio
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED

Verified with Firefox 84.0a1 (20201103095421) on Windows 10x64, macOS 10.12 and Ubuntu 18.04. The Notify me about new features can be selected using the Tab key and checked/ unchecked with Enter/Space keys.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.