Closed Bug 1669922 Opened 1 year ago Closed 1 year ago

Scale options are no longer working inside the old UI

Categories

(Core :: Print Preview, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1669187
Tracking Status
firefox82 --- affected
firefox83 --- affected

People

(Reporter: Anca, Unassigned)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression, Whiteboard: [print2020_v83] [old-ui+])

Attachments

(1 file)

Attached image screencast issue.gif

Affected versions

  • 83.0a1 (2020-10-07)
  • 82.0b8

Affected platforms

  • Windows 10
  • Windows 7
  • Ubuntu 18.04

Unaffected platforms

  • macOS 10.15.7

Steps to reproduce

  1. Launch Firefox
  2. Make sure print.tab-modal.enabled is set on false
  3. Open any page
  4. Open Print preview
  5. Choose any scale except 100% and Shrink to fit

Expected result

  • The scale options can be applied, the print preview content is adjusted accordingly

Actual result

  • Only Shrink to fit and 100% can be set as scale options

Regression range

Additional notes

  • Not reproducible with the new UI
  • If save to pdf or actual printing is done previously with the new UI, than going to the old one, the issue is no longer reproducible (but only setting print.tab-modal.enabled to true doesn't make any difference)

Suggested severity

  • S2
Has Regression Range: --- → yes
Has STR: --- → yes

Actually the issue is fixed after the first print is done from the old UI. Looks like this is closely linked to 1669187 and/or 1668621.

(In reply to Anca Soncutean [:Anca], Desktop Release QA from comment #1)

Actually the issue is fixed after the first print is done from the old UI. Looks like this is closely linked to 1669187 and/or 1668621.

Just about to ask that question. :-)
Yes pretty sure this is the same root cause then.

Regressed by: 1667953

Should be fixed in bug 1669187.

Depends on: 1669187

Yeah, the patch for bug 1669187 fixes this, at least to the extent we can without taking on too much risk. I'm just going to mark this as a dup.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1669187
You need to log in before you can comment on or make changes to this bug.