Closed Bug 1670132 Opened 1 year ago Closed 9 months ago

No hint for inline image is created for some part of multi-part message in MIME format

Categories

(Thunderbird :: Message Reader UI, defect)

defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: Robert_Hartmann, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:81.0) Gecko/20100101 Firefox/81.0

Steps to reproduce:

Windows - TB 78.3.2 (32bit)

  1. Create a HTML-Message and insert a Screenshot.
  2. send that mail (with PGP signing activated) to your self

Actual results:

The message Reader visualized the mail in text from
concrete the part "Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: quoted-printable"
without any hint that there is an inline graphic in html-part

Expected results:

I think there should be a hint, (for text mode only view),
that there is an inline graphic.
Ihink that object
Content-Type: image/png; name="gkbanmbokfnfgaai.png"
Content-Transfer-Encoding: base64
Content-ID: <.....>
Content-Disposition: inline;
filename="gkbanmbokfnfgaai.png"
should be accessible like an attachement, if the message reader is only showing the Content-Type: text/plain part

Since there is an simmilar but 11 years old bug - closed about seven years ago,
see bug 547139 ( https://bugzilla.mozilla.org/show_bug.cgi?id=547139 ) ,
I created that new report which only need TB 78.3.2 and where Outlook is not involved.

Maybe the current behavior "not to give a hint that there is an inline graphic"
is a design decision based on some security themes discussed some years ago,
see bug 1367156 comment 17 ( https://bugzilla.mozilla.org/show_bug.cgi?id=1367156#c17 )

or the behavior depends on
bug 671056 ( https://bugzilla.mozilla.org/show_bug.cgi?id=671056 )

Blocks: tb78found

At the time of writing the description, I thought that the Message Plane had shown the text-only part.
But I was wrong.
If I activate "Ansicht"->"Nachrichteninhalt"->"Reiner Text" (pure text) than the inline *.png graphic is available as attachement to download. Perfect!
But if I activate "Original HTML" or "Vereinfachtes HTML" than the inline png is not shown as attachement nor is shown inline the mail text.

If I had a look to that mail via a webmail interface using Firefox, that the inline graphic is visable to the reader.

Summary: No hint for inline image is created for text-only part of multi-part message in MIME format → No hint for inline image is created for some part of multi-part message in MIME format

(In reply to Robert Hartmann from comment #0)

Actual results:

The message Reader visualized the mail in text from

I assume that is because you have forced you view mode to plain text?
It would not be a reasonable experience to show other parts as attachments for such cases.

(In reply to Magnus Melin [:mkmelin] from comment #3)

(In reply to Robert Hartmann from comment #0)

Actual results:

The message Reader visualized the mail in text from

I assume that is because you have forced you view mode to plain text?

Well normaly I realy force TB to show "plain text" only. So I thought it was in plain text mode.
But TB wasn't in "plain text" mode and should show the inline screenshot of the mail.

It would not be a reasonable experience to show other parts as attachments for such cases.

I take three pictures, just to demonstrate, what I want to say:

  1. As you can see in comment 4 I create a html mail with an inline screenshot, shown correctly before sending the mail.

  2. In comment 5 TB displayed the pure text part and correctly the inline graphic as "attachement".

  3. But in comment 6 TB should display the text and the inline graphic because the setting is View "original HTML". But no inline graphic is shown AND no graphic as attachement.

Is it reproducible?

(In reply to Magnus Melin [:mkmelin] from comment #8)

Is it reproducible?

I cannot reproduce it anymore with

  • release: TB 78.5.1
  • beta: TB 84.0b4
  • daily: TB 85.0a1 (2020-12-07)

Best regards, Robert

Thanks for the updated info

Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.