Closed Bug 1670416 Opened 1 year ago Closed 26 days ago

webdav acls not checked during setup

Categories

(Calendar :: Provider: CalDAV, enhancement)

Thunderbird 82
enhancement

Tracking

(thunderbird_esr91+ affected, thunderbird92 affected)

RESOLVED FIXED
93 Branch
Tracking Status
thunderbird_esr91 + affected
thunderbird92 --- affected

People

(Reporter: dpa-mozilla, Assigned: lasana)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:81.0) Gecko/20100101 Firefox/81.0

Steps to reproduce:

With 82.0b2 I click "+ add calendar”, enter as server https://aaa.bapha.be, without user name, do Offline Support. → Find Calendars.

TB finds three calendars. I click on Properties.

For anonymous access the calendars are read-only, but the Properties do not show autmatic a tick before 'Read Only'. Neither do the WebDAV calls utilize the WebDAV ACL.

Actual results:

On setting up calendar use WebDAV ACL to find out, if a calendar is read-only and fill this in the Calendar Properties

Now for https://aaa.bapha.be two calendar-home-sets are returned, so to test this first https://bugzilla.mozilla.org/show_bug.cgi?id=1670415 has to be fixed.

xref bug 306495

Should hook up calACLUtils.jsm where appropriate I guess.

Status: UNCONFIRMED → NEW
Ever confirmed: true

Has this been fixed with bug 1665203 and is therefore a duplicate?

Per bug 1714586 the Calendar component overall does not work, so I cannot test if this has been fixed.

It seems that TB 91.0a1 does it right.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1665203
Duplicate of bug: 1715756

TB91-release does not make HTTP calls, during calendars setup, to find the ACL. In turn it does not mark as READ-ONLY calendars, which are READ-ONLY. This is a regression.

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Lasana, can you check this?

Flags: needinfo?(lasana)
Assignee: nobody → lasana
Flags: needinfo?(lasana)
Status: REOPENED → ASSIGNED
Target Milestone: --- → 93 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/81e03162ca75
Detect read-only acl privs for C:calendar-home-set. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 3 months ago26 days ago
Resolution: --- → FIXED
Duplicate of this bug: 1727920
You need to log in before you can comment on or make changes to this bug.