Search & Filter should trigger on "Sender:" header as well as "From::"

VERIFIED DUPLICATE of bug 40934

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 40934
16 years ago
10 years ago

People

(Reporter: David A. Cobb, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Some mailings are most easily identified by the content of the "Sender:" header.
 Mail-lists particularly often keep the "From:" as received from the author but
mung the "Sender: " to identify the list.  As the RFC indicates that "Sender:"
identifies an agent of the author responsible for actually posting the mail,
this is a pretty reasonable interpretation.

However, if I select "Sender " "is " <string>, the search/filter will not see
the string in the "Sender:" header -- it should examine both "From: " and
"Sender: ".

(Using Moz 2002-09-05-08 on Win2000pro, FWIW)

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 40934 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

16 years ago
I beg to differ.  This bug specifically requests that filters & searches test
BOTH "sender: " and "from: ".  That does come out in the commentary for
Bug#40934, but it certainly isn't obvious from the summary.  May I suggest,
then, a change in the summary of 40934?  My requirement would /not/ be satisfied
if the tag name in the filters/search dialogs were changed to "From"!

Also, this bug explicitly requests that Search be modified similarly.  I'm
guessing they use the same code but I don't know that as a fact.
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.