Closed Bug 1673287 Opened 9 months ago Closed 9 months ago

Disabled range controls don't look right with the basic theme

Categories

(Core :: Widget, defect)

defect

Tracking

()

RESOLVED FIXED
84 Branch
Tracking Status
firefox84 --- fixed

People

(Reporter: mstange, Assigned: mstange)

References

Details

Attachments

(3 files)

Spec: https://mozilla.invisionapp.com/share/5CX2MH6EHFB#/screens/415584863_Form_Widgets
Testcase: http://stephenhorlander.com/form-controls.html
(with widget.disable-native-theme-for-content set to true)

On disabled range controls, the range thumb currently reacts to hover and mousedown. The thumb also isn't properly transparent. And making the thumb transparent would make the track pieces behind it visible.

This feels a bit nicer but the difference isn't visible to the user.
But it demonstrates how we can fix progress bars.

This makes the thumb respect the disabled, active and hover state of the range
control.

Depends on D94699

This makes the disabled state look good because the track pieces are no longer
visible behind the partially-transparent disabled thumb.

Depends on D94700

Pushed by mstange@themasta.com:
https://hg.mozilla.org/integration/autoland/rev/c586fc967b88
Draw range progress and track pieces with the same rounded rect but different rectangular clips. r=spohl
https://hg.mozilla.org/integration/autoland/rev/783918e69c25
Draw thumb as part of the range control. r=spohl
https://hg.mozilla.org/integration/autoland/rev/8eeb925b28d5
Clip out the range thumb when drawing the progress and track pieces. r=spohl
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch
Regressions: 1673864
No longer regressions: 1673864
Regressions: 1673923
You need to log in before you can comment on or make changes to this bug.