Closed Bug 1674273 Opened 4 years ago Closed 4 years ago

Crash in [@ HyperTextIterator::NormalizeForward]

Categories

(Core :: Disability Access APIs, defect, P1)

Desktop
macOS
defect

Tracking

()

RESOLVED FIXED
84 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox81 --- unaffected
firefox82 --- wontfix
firefox83 --- wontfix
firefox84 --- fixed

People

(Reporter: aryx, Assigned: eeejay)

References

Details

(Keywords: crash, Whiteboard: [Mac2020_2])

Crash Data

Attachments

(1 file)

macOS-only crash which affects Firefox 82+. The files in the stack saw a bunch of changes in the 82 cycle (bug 1660290 etc.)

Crash report: https://crash-stats.mozilla.org/report/index/450517f2-7e14-4aa3-9e57-f1f530200924

Reason: EXC_BAD_ACCESS / KERN_INVALID_ADDRESS

Top 10 frames of crashing thread:

0 XUL HyperTextIterator::NormalizeForward accessible/mac/HyperTextAccessibleWrap.mm:66
1 XUL HyperTextIterator::Next accessible/mac/HyperTextAccessibleWrap.mm:179
2 XUL mozilla::a11y::HyperTextAccessibleWrap::TextForRange accessible/mac/HyperTextAccessibleWrap.mm:200
3 XUL mozilla::a11y::GeckoTextMarkerRange::Text const accessible/mac/GeckoTextMarker.mm:336
4 XUL -[MOXTextMarkerDelegate moxStringForTextMarkerRange:] accessible/mac/MOXTextMarkerDelegate.mm:122
5 XUL -[MOXTextMarkerDelegate moxLengthForTextMarkerRange:] accessible/mac/MOXTextMarkerDelegate.mm:126
6 XUL -[MOXAccessibleBase accessibilityAttributeValue:forParameter:] accessible/mac/MOXAccessibleBase.mm:326
7 AppKit ___NSAccessibilityEntryPointValueForAttributeWithParameter_block_invoke.821 
8 AppKit NSAccessibilityPerformEntryPointObject 
9 AppKit NSAccessibilityEntryPointValueForAttributeWithParameter 
Flags: needinfo?(eitan)
Severity: -- → S2
Priority: -- → P1
Hardware: Unspecified → Desktop
Whiteboard: [Mac2020_2]
Assignee: nobody → eitan
Status: NEW → ASSIGNED

I don't use voiceover support.

Any examples of other assistive features on macOS?
So, we can narrow down the causes:)

Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/efff416839c9
Consider a hyperlink with no hypertext parent as a root. r=morgan
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch
Flags: needinfo?(eitan)

(In reply to ⚜️Québec🇨🇦Canada🍁 from comment #3)

I don't use voiceover support.

Any examples of other assistive features on macOS?
So, we can narrow down the causes:)

I don't use accessibility services and have the "Prevent accessibility services from accessing your browser" option checked as always until Firefox removed this option recently...

Here's an old screenshot:
https://techdows.com/wp-content/uploads/2017/09/Firefox-57-disable-accessbility-services.png

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: