no printers => cancel => PrintSettings arg is null

RESOLVED INCOMPLETE

Status

()

--
trivial
RESOLVED INCOMPLETE
17 years ago
a year ago

People

(Reporter: timeless, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Future
All
BeOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
steps:
setup your macintosh without any printers/drivers
run mozilla (i used the newly functioning carbon build 
ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-macosX-trunk.smi.bin on 
macos 9.0.4, it might crash the first time it runs, but it runs the second time)

select file>print preview
get a dialog complaining that there is no default printer.
click cancel.
actual results: get this dialog.
expected results: i clicked cancel, i shouldn't get any more dialogs.
(Reporter)

Comment 1

17 years ago
Created attachment 98407 [details]
PrintSettings arg is null!

Updated

17 years ago
Severity: normal → trivial
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 2

17 years ago
--> don
Assignee: rods → dcone
Status: ASSIGNED → NEW

Comment 3

16 years ago
I just sumpled on this bug (when confirming bug 187127), but I didn't see the
error. I crashed with TB15613841M. See also the Talkback-id's in bug 187127.

Comment 4

16 years ago
build 2002122708 on Mac OS 9.2.2

Updated

16 years ago
Blocks: 125824
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".

Comment 6

15 years ago
Since Mozilla is no longer supported on Mac OS X pre-OS X I am attepting to test
the remaining open bugs (all 175 of them).

The test client will be the Mozilla (SeaMonkeys) 1.6 running Mac OS X 10.3.2

Result/Status: Does not exist in Mozilla 1.6, pure CFM/OS 9 bug
(Reporter)

Comment 7

15 years ago
i don't think this is a pure macos9 bug, i believe something similar happened on
beos. unfortunately windows is showing all of my printers to my restricted guest
account, which means it'll take way too much effort for me to test.
Mac OS Classic bug. Marking WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 9

15 years ago
risc@risckyworkings.com: how did you try to test this?
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 10

15 years ago
Well under 10.3.2 with Mozilla 1.6 release I...

1.) Opened Print Center and removed all printers -> no printers (my laptop has
no print drivers even installed but checked just in case) 
2.) Launched mozilla3.) File -> Print
(print sheet apears)
4.) Cancel
(Reporter)

Comment 11

15 years ago
erm, did you pay any attention to the steps to reproduce or the component?

Comment 12

15 years ago
Well print preview is PDF based right... so Print Preview spools a PDF and Opens
"Preview.app". Preview then lets you print with the "Print" button (default) or
cancel with the cancel "Cancel" button. When you press cancel and return to
Mozilla print dialog is gone... and no pop-up error messege.

I can not reproduce this bug at all. Once you do a print preview Mozilla no
longer "owns" the print job... you print the document with Preview.
OS: Mac System 9.x → BeOS
Hardware: Macintosh → All
(Bug was changed without comment from MAC to BeOS.)

Is this bug still a problem for BeOS or MAC?
Assignee: dcone → printing
Status: REOPENED → NEW
QA Contact: sujay
Assignee: printing → nobody
QA Contact: printing
Besides anything else, I think most OS's come with print-to-PDF drivers built in, so I'm not sure this would be an issue any more.
Status: NEW → RESOLVED
Last Resolved: 15 years agoa year ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.