Closed Bug 1674650 Opened 11 months ago Closed 10 months ago

Contacts after a Contact List are lost from To:, Bcc:, Cc: when opening draft or template

Categories

(Thunderbird :: Message Compose Window, defect, P1)

Tracking

(thunderbird_esr78 fixed)

VERIFIED FIXED
84 Branch
Tracking Status
thunderbird_esr78 --- fixed

People

(Reporter: wsmwk, Assigned: rnons)

References

(Blocks 1 open bug, )

Details

(Keywords: regression)

Attachments

(1 file)

Reported in https://support.mozilla.org/en-US/questions/1311240

If a contact list is the first of multiple contacts in TO, BCC, etc in a draft or template, then compose window has only the "list" when opening the draft or template.

For example, a saved template with
To: <pizza crew>, <me>
opens in compose with just
To: <pizza crew>

I created a bug 1674652
It contains a bit more info with some testing.

Current workaround would be to put the mailing list last.

Duplicate of this bug: 1674652

To clarify, my testing was on 83 beta and the items in bug 1674652 are correct - but not limited to Bcc and templates.

Summary: Contacts after a Contact List are lost when opening draft or template → Contacts after a Contact List are lost from To:, Bcc:, Cc: when opening draft or template
Assignee: nobody → remotenonsense
Severity: -- → S1
Priority: -- → P1

Realistically, this is not a release blocker. marginally dataloss.

Severity: S1 → S2
Status: NEW → ASSIGNED

Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/97973d6a7073
Fix makeFromDisplayAddress to support contact list. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch

Comment on attachment 9185645 [details]
Bug 1674650 - Fix makeFromDisplayAddress to support contact list. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): When makeFromDisplayAddress was used by CompFields2Recipients
User impact if declined: Recipients after contact list are lost when opening draft or template
Testing completed (on c-c, etc.): Yes
Risk to taking this patch (and alternatives if risky): Low

Attachment #9185645 - Flags: approval-comm-esr78?
Attachment #9185645 - Flags: approval-comm-beta?

Changes in this area affect Thunderbird across the application, and can easily have unexpected outcomes, so should definitely bake on beta (maybe a full beta) before ESR.

Comment on attachment 9185645 [details]
Bug 1674650 - Fix makeFromDisplayAddress to support contact list. r=mkmelin

[Triage Comment]
We don't plan another beta for uplifts - so this will appear in beta 84.

To avoid confusion I'm minusing for esr78, but please request again in a couple weeks after beta bake is completed

Flags: needinfo?(remotenonsense)
Attachment #9185645 - Flags: approval-comm-esr78?
Attachment #9185645 - Flags: approval-comm-esr78-
Attachment #9185645 - Flags: approval-comm-beta?
Attachment #9185645 - Flags: approval-comm-beta-

Comment on attachment 9185645 [details]
Bug 1674650 - Fix makeFromDisplayAddress to support contact list. r=mkmelin

Hi Wayne, the form is showing wsmwk: approval-comm-esr78 -, I'm unable to request again.

Flags: needinfo?(remotenonsense) → needinfo?(vseerror)

Comment on attachment 9185645 [details]
Bug 1674650 - Fix makeFromDisplayAddress to support contact list. r=mkmelin

[Triage Comment]
Approved for esr78.6.0

Flags: needinfo?(vseerror)
Attachment #9185645 - Flags: approval-comm-esr78- → approval-comm-esr78+

Verified in testing of the Thunderbird 78.6.0 release candidate on Windows 10.

Status: RESOLVED → VERIFIED
Duplicate of this bug: 1664039
You need to log in before you can comment on or make changes to this bug.