Closed Bug 1675031 Opened 11 months ago Closed 11 months ago

Crash in [@ libsystem_kernel.dylib@0x1f016]

Categories

(Core :: Printing: Output, defect, P1)

Firefox 83
Unspecified
macOS
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr78 --- unaffected
firefox82 --- unaffected
firefox83 --- wontfix
firefox84 --- fixed

People

(Reporter: emilghitta, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: crash, Whiteboard: [print2020_v84] [old-ui?] [Fixed by 1674135] )

Crash Data

Crash report: https://crash-stats.mozilla.org/report/index/a6850f74-31dc-459d-89c7-14a4d0201103

Reason: EXC_SOFTWARE / SIGABRT

Top 10 frames of crashing thread:

0 libsystem_kernel.dylib libsystem_kernel.dylib@0x1f016 
1 libsystem_kernel.dylib libsystem_kernel.dylib@0x1a588 
2 libobjc.A.dylib _objc_fatalv 
3 libobjc.A.dylib _objc_fatal 
4 libobjc.A.dylib lookUpImpOrForward 
5 libobjc.A.dylib _objc_msgSend_uncached 
6 Foundation -[NSPlaceholderString initWithString:] 
7 Foundation +[NSString stringWithString:] 
8 KfSummary KfSummary@0xd303 
9 KfSummary KfSummary@0xcb25 

Encountered this random crash while using Firefox 83.0b7 on macOS 10.14.

I couldn't reproduce the crash using the exact same steps again (so they are no reliable):

Preconditions

  • Set print.tab_modal_enabled to true

Steps to reproduce:

  1. Launch Firefox.
  2. Access the about:support page.
  3. Select a random text.
  4. Select the "Print selection" from the context menu.
  5. Click the "Print using the system dialog" option.
  6. Print the selection.

Note

  • I'll try to reproduce this again and find some more reliable steps.

I wonder if this will be resolved with bug 1674135. Will keep an eye on it.

Severity: -- → S2
Priority: -- → P1
See Also: → 1674135

Sure smells like it.

Hi Emil: Can you try to reproduce this again in Nightly at some point now that bug 1674135 has landed?

Flags: needinfo?(emil.ghitta)

I tried to poke this several times but couldn't reproduce this crash in latest Nightly.

I'm going to mark this as Fixed but this scenario will be covered again in our beta 84 feature test runs and I'll reopen this issue if encountered again.

Status: NEW → RESOLVED
Closed: 11 months ago
Flags: needinfo?(emil.ghitta)
Resolution: --- → FIXED
Whiteboard: [print2020_v84] [old-ui?] → [print2020_v84] [old-ui?] [Fixed by 1674135]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.