Hard drive full chimera quits and deletes bookmarks

VERIFIED FIXED

Status

P2
major
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: james, Assigned: sfraser_bugs)

Tracking

({dataloss, qawanted, verifyme})

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
My hard drive became full and Chimera stopped working with the message "file
could not be found" when I tried to load any page.

I quit and restarted Chimera and it unexpectedly quit.  Figuring out that the
drive was full I made room and restarted Chimera.

All bookmarks were lost.

Cheers
James

Comment 1

16 years ago
James, what build ID are you reporting this bug against?
(Reporter)

Comment 2

16 years ago
I think that more than the bookmarks were killed - the preferences in general
seemed to have been corrupted.

I cannot find a build number other than 0.4.0 release?

I have tar'd up the Application Support folder and could attach it.

After the even I found the app to freeze on about the third page it tried to
load.  It was as though it had been loaded but not displayed?

Plesae let me know if the folder is of use.

I have since upgraded to the latest nightly.

Comment 3

16 years ago
James, please retest using the recent nightly and let us know what build ID it is.
(Reporter)

Comment 4

16 years ago
Ok - I've tried this again with build ID: 2002090905.

I note that the finder also loses its preferences in this situation - the dock
reverts to the bottom with the basic applications in it.  So this may not be a
bug in Chimera so much as the way the system handles running out of diskspace.

Lost all preferences again.

Got to buy a bigger disk.

Comment 5

16 years ago
*** Bug 177540 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

16 years ago
Saving bookmarks needs to use a safe save mechanism.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 7

16 years ago
Created attachment 104679 [details]
Console log from out of disk crash

This is the console log from a crash like this.  Unfortunately even though it
says it's writing to the navigator.crash.log, no data made it in there.

Like the original bug reporter, I too lost my finder settings as well, however
my dock seems to be fine.

Comment 8

16 years ago
Sam was your drive full too? Or just a random crash?

Comment 9

16 years ago
Ah sorry, that was all in Bug 177540.

Yeah my drive filled up.  I need to watch that closer.
(Assignee)

Comment 10

16 years ago
*** Bug 179409 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Keywords: dataloss
Priority: -- → P2
Keywords: qawanted
(Assignee)

Comment 11

16 years ago
We save to a temp file which gets renamed now, so we should no longer lose data.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
James --and anyone else who's encountered this problem-- could you please see if
this still a problem with tomorrow's build? (that'll be the first build that'll
have the fix.) thanks a lot!
Keywords: verifyme
rs vrfy...but reopen if this is still a problem with a *recent* chimera build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.