Closed Bug 1675455 Opened 11 months ago Closed 11 months ago

Print preview - TAB navigation on More Settings section throws Uncaught TypeError: can't access property "includes", e.target.step is undefined

Categories

(Toolkit :: Printing, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1668849
Tracking Status
firefox-esr78 --- unaffected
firefox82 --- unaffected
firefox83 --- wontfix
firefox84 --- wontfix

People

(Reporter: cfogel, Unassigned)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression, Whiteboard: [print2020_v84] [old-ui-])

Attachments

(1 file)

Affected versions

  • 84.0a1 (2020-11-04), 83.0b8

Affected platforms

  • macOS 10.15, Windows 10, Ubuntu 20;

Steps to reproduce

  1. Launch Firefox, access any website ex.
  2. CTRL+P to open print preview, expand the More Settings section;
  3. Use the TAB key to navigate in options from the PrintPreview interface;

Expected result

  • no errors occur;

Actual result

  • Error thrown in console:
    Uncaught TypeError: can't access property "includes", e.target.step is undefined
    handleKeypress chrome://global/content/print.js:1336
    handleEvent chrome://global/content/print.js:2036
    initialize chrome://global/content/print.js:1917
    connectedCallback chrome://global/content/print.js:1299
    <anonymous> chrome://global/content/print.js:2100
    print.js:133

Regression range

  • First bad: 2020-10-01
  • Last good: 2020-09-30
  • Pushlog: URL;
  • Potential regressor: bug 1664570

Additional notes

  • attached image to illustrate the issue;
  • S4 as suggested severity since it doesn't seem to have an impact over usability.

Updated flags based on indicated regressor.
@Emma, mind confirming if it is accurate? Thanks!

Has Regression Range: --- → yes
Has STR: --- → yes
Component: Print Preview → Printing
Flags: needinfo?(emalysz)
Keywords: regression
Product: Core → Toolkit

Yeah, the error is from the margin select box, so going to make this a dupe of Bug 1668849.

Status: NEW → RESOLVED
Closed: 11 months ago
Flags: needinfo?(emalysz)
Resolution: --- → DUPLICATE
Duplicate of bug: 1668849
You need to log in before you can comment on or make changes to this bug.