Closed Bug 1676101 Opened 11 months ago Closed 11 months ago

Remove browser.partnerlink.useAttributionURL pref

Categories

(Firefox :: Top Sites, task, P1)

task
Points:
1

Tracking

()

RESOLVED FIXED
84 Branch
Iteration:
84.2 - Nov 2 - Nov 15
Tracking Status
firefox82 --- unaffected
firefox83 --- wontfix
firefox84 --- fixed

People

(Reporter: dao, Assigned: dao)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

From what I can tell, we can always use browser.partnerlink.attributionURL at this point. Short of that, I think it would be preferable to keep browser.topsites.useRemoteSetting as an implied way to use browser.partnerlink.attributionURL, to avoid the foot-gun of not having set browser.partnerlink.useAttributionURL which I suspect people involved with the remote setting experiment aren't aware of yet (at least I was completely unaware until I stumbled upon bug 1674138).

Iteration: --- → 84.2 - Nov 2 - Nov 15
Points: --- → 1
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/722522a451a9
Remove browser.partnerlink.useAttributionURL pref. r=mikedeboer

Comment on attachment 9186592 [details]
Bug 1676101 - Remove browser.partnerlink.useAttributionURL pref. r=mikedeboer

Beta/Release Uplift Approval Request

  • User impact if declined: Potential confusion for people involved with testing and setting up the top sites experiment for 83 due to the late addition of the browser.partnerlink.useAttributionURL pref
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Trivial fix
  • String changes made/needed:
Attachment #9186592 - Flags: approval-mozilla-release?
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch

Comment on attachment 9186592 [details]
Bug 1676101 - Remove browser.partnerlink.useAttributionURL pref. r=mikedeboer

@mikedeboer is telling me that by now all stakeholders are aware of the pref so we don't need to uplift this.

Attachment #9186592 - Flags: approval-mozilla-release?
Blocks: 1653936
You need to log in before you can comment on or make changes to this bug.