Closed Bug 1677316 Opened 5 months ago Closed 5 months ago

SeaMonkey is showing blank popup menus and folder trees after upgrading to macOS Big Sur [11.0]

Categories

(SeaMonkey :: General, defect)

SeaMonkey 2.53 Branch
Unspecified
macOS
defect

Tracking

(seamonkey2.53+ fixed, seamonkey2.57esr? affected)

RESOLVED FIXED
Tracking Status
seamonkey2.53 + fixed
seamonkey2.57esr ? affected

People

(Reporter: jean-marc.lienher, Unassigned)

References

Details

(Whiteboard: SM2.53.5.1)

User Story

Workaround by Thomas Hallgren at NG mozilla.support.seamonkey:

A workaround that works for me is to switch to the "SeaMonkey Modern" theme.
(View -> Apply Theme -> SeaMonkey Modern. A blank popup will appear. It is
supposed to say that theme changes take effect when you restart SeaMonkey. You
can press Enter to restart now or Esc to restart later.)

Attachments

(3 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.16; rv:83.0) Gecko/20100101 Firefox/83.0

Steps to reproduce:

Install Seamonkey 2.53.5 English (US) macOs x64.
Start Seamonkey and open "About SeaMonkey".
Click on "Bookmarks".

Actual results:

Pop up a blank menu window.

Expected results:

A Window with clickable sub menu links.

You can reproduce this bug by clicking on several other buttons that open a sub menu popup.

Attached image MacBook config
See Also: → 1677273
OS: Unspecified → macOS
Duplicate of this bug: 1677410

NEW due to confirmation via "Bug 1677410 - [macOS 11.0.1 Big Sur] Drop-down menus all show blank"

Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: [macOs 11.0 big sur] blank popup menu → [macOs 11.0 big sur] blank popup menus

Just to add that this makes SeaMonkey effectively unusable unless you want to do all your editing in raw HTML. It is a showstopper.

I confirm that the mail folder panel is blank too as indicated in bug 1677273.

User Story: (updated)

(Commenting on User Story)

Workaround by Thomas Hallgren at NG mozilla.support.seamonkey:

A workaround that works for me is to switch to the "SeaMonkey Modern" theme.
(View -> Apply Theme -> SeaMonkey Modern. A blank popup will appear. It is
supposed to say that theme changes take effect when you restart SeaMonkey.
You
can press Enter to restart now or Esc to restart later.)

It works for me too. Thanks.

And it worked for me - so thanks as well.

Duplicate of this bug: 1677273

Apple broke compatibility with existing Applications. Again after doing it already with 10.14 ans 10.15 but that is another story.

It would be great if someone can test the current unofficial 2.53.6b1 pre at https://www.wg9s.com/comm-253/ asap.

It is still profile compatible. If you want to go back afterwards you just need to reinstall 2.53.5 and then reinstall the older Lightning version provided with it via the instructions in the release notes. I just tested the build with 10.15.7 but my late mini mac 2012 is no longer compatible with Big Sur. Thanks again Apple.

If this build works for you please post here. We want to do a 2.53.5.1 immediately afterwards.

Flags: needinfo?(jean-marc.lienher)
Summary: [macOs 11.0 big sur] blank popup menus → SeaMonkey is showing blank popup menus and folder trees after upgrading to macOS Big Sur [11.0]

(In reply to Frank-Rainer Grahl (:frg) from comment #10)

Apple broke compatibility with existing Applications. Again after doing it already with 10.14 ans 10.15 but that is another story.

It would be great if someone can test the current unofficial 2.53.6b1 pre at https://www.wg9s.com/comm-253/ asap.

It is still profile compatible. If you want to go back afterwards you just need to reinstall 2.53.5 and then reinstall the older Lightning version provided with it via the instructions in the release notes. I just tested the build with 10.15.7 but my late mini mac 2012 is no longer compatible with Big Sur. Thanks again Apple.

If this build works for you please post here. We want to do a 2.53.5.1 immediately afterwards.

I tried the build and the problem is resolved: mail folder tree appears as expected in SeaMonkey Default Theme.

Thank goodness because while workable, Modern is ooooglay! :P

(In reply to Frank-Rainer Grahl (:frg) from comment #10)

If this build works for you please post here. We want to do a 2.53.5.1 immediately afterwards.

seamonkey-2.53.6b1pre.en-US.mac.dmg works for me.

Flags: needinfo?(jean-marc.lienher)
Blocks: 1677306

Thanks for testing. Will be (hopefully) fixed in an official interim release 2.53.5.1 soon. The prerelease is fine and you can keep using it too. Has a ton of other fixes already in. Some are not fully reviewed yet and might cause minor bugs. If you find one let me/us know :)

2.53.6 beta 1 pre works fine for me. Of course, I had to revert the Theme workaround back to SeaMonkey Default, but that theme now works.

2.53.6 beta 1 also works for me. While you are working on this bug, here's another that someone more knowledgeable about Bugzilla can move to the correct place. When I try to log into google, I get: "The browser you're using doesn't support JavaScript, or has JavaScript turned off." In fact, JavaScript is turned on. This appears to actually be a part of a larger "bug" where SeaMonkey no longer works with many websites. It's not on many "official" browser lists that websites "support". Firefox is. So I have Firefox (and Thunderbird) set up. But I really like how SeaMonkey works a whole lot better. It used to be that those websites treated SeaMonkey as if it were Firefox. Can that feature be added back to SeaMonkey?

Fixed in 2.53.5.1

Gordon: google now frequently breaks SeaMonkey. We are backporting newer features as fast as time permits. They don't care about anything but Chrome and their services should be avoided if possible.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Whiteboard: SM2.53.5.1
You need to log in before you can comment on or make changes to this bug.