Closed Bug 1677647 Opened 2 months ago Closed 2 months ago

[Link] Button on Filelink info bar fails to open up Filelink section in Options

Categories

(Thunderbird :: Preferences, defect, P3)

Tracking

(thunderbird_esr78+ fixed, thunderbird84 fixed)

RESOLVED FIXED
85 Branch
Tracking Status
thunderbird_esr78 + fixed
thunderbird84 --- fixed

People

(Reporter: thomas8, Assigned: khushil324)

References

(Regression)

Details

Attachments

(1 file)

STR

  1. Compose message
  2. Attach large attachment > 5 MB
  3. Choose [Link] button on yellow Filelink info bar which appears

Actual Result

  • Options tab opens on General section
  • Does not open Composition > Attachments section where Filelink can be set up
  • For regular users, this renders the entire Filelink feature de facto unavailable as they won't know where to start with it (hence S2).

Expected Result

  • Options tab should be opened directly on the Composition > Attachments section which includes the settings for Filelink
Assignee: nobody → khushil324
Attachment #9188259 - Flags: review?(mkmelin+mozilla)
Status: NEW → ASSIGNED
Regressed by: 1565789
Comment on attachment 9188259 [details] [diff] [review]
Bug-1677647_Filelink-Pref-link-not-working-0.patch

Review of attachment 9188259 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks Kushil, this looks promising! ;-)

If it wasn't for protocol, I could have reviewed this one-liner, but alas, it's just f+ from me.
Attachment #9188259 - Flags: feedback+
Attachment #9188259 - Flags: review?(mkmelin+mozilla) → review+
Target Milestone: --- → 85 Branch

Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/753a8a4d305f
Fix Button on Filelink info bar fails to open up Filelink section in Options. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Comment on attachment 9188259 [details] [diff] [review]
Bug-1677647_Filelink-Pref-link-not-working-0.patch

[Approval Request Comment]
Regression caused by (bug #): 1565789
User impact if declined: Opening the Options tab from Filelink info bar will not lead to the right section.
Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky): Low

Attachment #9188259 - Flags: approval-comm-esr78?
Attachment #9188259 - Flags: approval-comm-beta?

Comment on attachment 9188259 [details] [diff] [review]
Bug-1677647_Filelink-Pref-link-not-working-0.patch

[Triage Comment]
Approved for beta

Attachment #9188259 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9188259 [details] [diff] [review]
Bug-1677647_Filelink-Pref-link-not-working-0.patch

[Triage Comment]
Approved for esr78

Attachment #9188259 - Flags: approval-comm-esr78? → approval-comm-esr78+

78.5.1

You need to log in before you can comment on or make changes to this bug.