Closed Bug 1677691 Opened 10 months ago Closed 10 months ago

[Win7] Drop down password menus are sometimes invisible with Webrender

Categories

(Core :: Graphics: WebRender, defect)

Desktop
Windows 7
defect

Tracking

()

VERIFIED FIXED
85 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox82 --- unaffected
firefox83 --- unaffected
firefox84 + verified
firefox85 + verified

People

(Reporter: atrif, Assigned: gw)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: correctness, regression)

Attachments

(2 files)

Attached image dropdown_w7_01.gif

Affected versions

  • 84.0b1 (20201116212331)
  • 85.0a1(20201116210217)

Affected platforms

  • Windows 7x64

Steps to reproduce

  1. Open Firefox and go to a login site (e.g Facebook/ Twitter).
  2. Focus the page and the focus username field.

Expected result

  • Dropdown is displayed as expected.

Actual result

  • Dropdown is invisible. If not reproduced repeat to focus the page and username field.

Regression range

Notes

  • Attached a screen recording.
  • I cannot reproduce the issue on Windows 10x64, macOS 10.12 or Ubuntu 18.04.
  • Note that the issue is intermittent.
  • When hovered the dropdown menu is displayed as expected.
  • The issue is not reproducible without WebRender.

Suggested Severity: S3

Has Regression Range: --- → yes
Has STR: --- → yes

Jeff is going to see if he can repro this on a win7 machine. It should be easy enough to back out (and uplift to beta) if needed, it's a small isolated change. It is odd though, since in theory that change should have had no effect except removing a potential race condition.

Flags: needinfo?(jmuizelaar)

:atrif, can you attach about:support to this bug?

Flags: needinfo?(alexandru.trif)

I have Win7 PC and confirmed that I could reproduce the problem.

Attached file about_support.zip

(In reply to Sotaro Ikeda [:sotaro] from comment #2)

:atrif, can you attach about:support to this bug?

Yes. Attaching here from two machines on which we were able to replicate the issue. If more information is needed please let me know. Thank you!

Flags: needinfo?(alexandru.trif)
Blocks: wr-win7
Keywords: correctness

Looks like Sotaro can reproduce so I'm not going to try.

Flags: needinfo?(jmuizelaar)

Sotaro, could you confirm if reverting the linked regressing patch does fix it? If so, let's just back that out of nightly and beta for now, until we have more time to investigate the root cause?

Flags: needinfo?(sotaro.ikeda.g)

I tested with local build on win7 PC. And I confirmed that reverting the patch fixed the problem.

Without reverting it, local build caused the problem. With reverting it, I did not see the problem.

Flags: needinfo?(sotaro.ikeda.g)
Blocks: gfx-triage
Assignee: nobody → gwatson
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch

The issue is verified fixed with Firefox 85.0a1 (20201208213457) and 84.0 (20201207203640) on Windows 7x64. The drop-down password menus are correctly displayed on Facebook and Twitter.

Status: RESOLVED → VERIFIED
No longer blocks: gfx-triage
You need to log in before you can comment on or make changes to this bug.