Closed Bug 1678415 Opened 2 years ago Closed 2 years ago

Support setting permissions when we create a directory with IOUtils

Categories

(Toolkit :: OS.File, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
85 Branch
Tracking Status
firefox85 --- fixed

People

(Reporter: emmamalysz, Assigned: barret)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We should be able to set the permissions when creating a directory. See https://searchfox.org/mozilla-central/source/toolkit/components/crashes/CrashManager.jsm#841-844 as an example.

Assignee: nobody → brennie
Severity: -- → S3
Status: NEW → ASSIGNED
Priority: -- → P3
Blocks: 975702
No longer blocks: 986145
Duplicate of this bug: 975702
Blocks: 1231711
No longer blocks: 975702
Pushed by brennie@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7c8678514d1a
Support setting file mode in IOUtils.createDirectory on non-Windows platforms r=emalysz
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch
You need to log in before you can comment on or make changes to this bug.