Closed Bug 1678616 Opened 2 months ago Closed 1 month ago

The elipsis menu can no longer be dismissed after clicking on a separator line or the greyed out "Remove All Logins" option

Categories

(Firefox :: about:logins, defect, P3)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
86 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox83 --- wontfix
firefox84 --- wontfix
firefox85 --- wontfix
firefox86 --- verified

People

(Reporter: cmuresan, Assigned: kenrick95)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Affected versions]:

  • Firefox Nightly 85.0a1 (Build ID: 20201119214432)

[Affected Platforms]:

  • Mac 10.15.6
  • Windows 10 x64
  • Ubuntu 20.04 x64

[Prerequisites]:

  • Have the latest version of Firefox Nightly installed.
  • Have a Firefox profile with no logins saved.

[Steps to reproduce]:

  1. Open the Firefox browser with the profile from prerequisites.
  2. Navigate to the "about:logins" page.
  3. Click on the Menu button and click on a separator line or the greyed out Remove All Logins option.
  4. Press the ESC key or a click outside the menu and observe the behavior.

[Expected result]:

  • The menu is dismissed.

[Actual result]:

  • The menu remains in place and can't be dismissed.

[Regression window]:
10:02.41 INFO: No more integration revisions, bisection finished.
10:02.41 INFO: Last good revision: bed3d8831e0fa0f9304e6f1ba555bff43ffe47fd
10:02.41 INFO: First bad revision: 76d60283a31c0f8deee59f0f687947c7a1a398f8
10:02.41 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=bed3d8831e0fa0f9304e6f1ba555bff43ffe47fd&tochange=76d60283a31c0f8deee59f0f687947c7a1a398f8

[Notes]:

  • Once this is done, the only way to dismiss the menu is to click the elipsis button again.
  • Attached a screen recording with the issue.

From the pushlog it looks like Bug has caused this behavior. @kenrick95 could you please take a look at this?

Flags: needinfo?(kenrick95)

Yup sure thing! Let me find a way to fix this behavior. Thanks for discovering the issue

Flags: needinfo?(kenrick95)
Assignee: nobody → kenrick95
Status: NEW → ASSIGNED
Priority: -- → P3
Pushed by sfoster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/283614fc4f74
Fix elipsis menu of about:logins no longer dismissable after menu button is no longer in focus r=sfoster,tgiles
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 86 Branch

I have verified this issue and is no longer reproducible using the latest Firefox Nightly 86.0a1 (Build ID: 20201215092954) on Windows 10 x64, Ubuntu 20.04 and Mac 10.15.7.

  • The Ellipsis menu can be successfully dismissed after clicking on a separator line or the greyed out "Remove All Logins" option.
Status: RESOLVED → VERIFIED

The patch landed in nightly and beta is affected.
:kenrick95, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(kenrick95)
Flags: needinfo?(kenrick95)
You need to log in before you can comment on or make changes to this bug.