Closed Bug 1678647 Opened 2 months ago Closed 2 months ago

CJK IME causing quitting searching mode

Categories

(Firefox :: Address Bar, defect, P3)

Firefox 83
x86_64
Windows 10
defect
Points:
3

Tracking

()

RESOLVED FIXED
85 Branch
Iteration:
85.2 - Nov 30 - Dec 13
Tracking Status
firefox-esr78 --- unaffected
firefox83 --- wontfix
firefox84 - wontfix
firefox85 - fix-optional

People

(Reporter: lolipopplus, Assigned: mak)

References

(Blocks 1 open bug)

Details

(Keywords: inputmethod)

Attachments

(1 file)

Attached video STR recording with IME

STR (as recording video part I):

  1. install any CJK IME and Firefox 83.0
  2. toggle awesome search mode with the IME
  3. type any word as search terms

Autall:
search mode is quit before the search term can be selected

note:
when adding a space before the search term, search mode won't quit (see recording video part II)

I can reproduce the issue on Nightly84.0a1 Windows10.

STR

  1. Focus Address bar
  2. IME ON
  3. Type amazon and choose a candidate string "amazon", then commit
  4. Select "Search with Amazon.com" from dropdown
    --- [Amazon.com] is indicated in the Address bar as expected
  5. Type any word
    --- BUG!. Search mode is quit. [Amazon.com] will disappear.
  6. Hit Enter
    --- BUG!. Search the word with Google :(
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: inputmethod

just some more details:
this bug can NOT be reproduced if:
a. you use @searchengine keyword
b. you click the engine manually

Also happened on Microsoft New Phonetic(bopomofo).
System: windows 20H2
Firefox: 83.0

Is it possible that a patch is introduced within train of 83?
This is a bit annoying bug though very old users might click the engine buttons so override this.

Flags: needinfo?(alice0775)

(In reply to lolipopplus from comment #4)

Is it possible that a patch is introduced within train of 83?

Sorry, I am not a developer.

Flags: needinfo?(alice0775)
Duplicate of this bug: 1679698

[Tracking Requested - why for this release]: Search from addressbar is broken

No priority and severity ?

Well, afaict this is not actually a regression, it just didn't work from the beginning of tab-to-search implementation.
and there are workarounds, as stated in comment 2.
Search is broken if tab to search is used, but not in the other cases, right?

Severity: -- → S3
Priority: -- → P3
Assignee: nobody → mak
Status: NEW → ASSIGNED
Iteration: --- → 85.2 - Nov 30 - Dec 13
Points: --- → 3
Blocks: 1679697

I posted some Try builds in https://bugzilla.mozilla.org/show_bug.cgi?id=1673669#c19, testing is welcome

Should have been fixed by Bug 1673669.

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Depends on: 1673669
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch
You need to log in before you can comment on or make changes to this bug.