Closed Bug 1679697 Opened 5 months ago Closed 5 months ago

`@bing 하나` unexpectedly opens Google instead of Bing with Korean IME

Categories

(Firefox :: Address Bar, defect, P1)

x86_64
Windows 10
defect

Tracking

()

VERIFIED FIXED
85 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox83 --- wontfix
firefox84 --- verified
firefox85 --- verified

People

(Reporter: saschanaz, Assigned: mak)

References

(Regression)

Details

(Keywords: regression)

  1. Get a new profile and Microsoft Korean IME (or optionally install Nalgaeset IME because it reproduces consistently on it while it's intermittent on MS IME)
  2. Type "@bing 하나" (GKSK in QWERTY)
  3. Tap Enter key while the composition is not finished yet (in other words, while the underline exists)

Expected: A search page with Bing
Actual: A search page with Google

See Also: → 1679005

Set release status flags based on info from the regressing bug 1647925

Thanks for the report. This sounds like a duplicate of bug 1678963.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1678963

Is bug 1678963 also a regression? I'd keep this until it turns out it's also a regression from the same commit.

(Feel free to close this again when someone confirms it.)

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

All these korean IME bugs are regressions, very likely the same one.

Depends on: 1673669
Flags: qe-verify+
Duplicate of this bug: 1678963
Depends on: 1678647
Severity: -- → S3
Priority: -- → P1

I posted some Try builds in https://bugzilla.mozilla.org/show_bug.cgi?id=1673669#c19, testing is welcome

Should have been fixed by Bug 1673669

Status: REOPENED → RESOLVED
Closed: 5 months ago5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch

(In reply to Marco Bonardo [:mak] from comment #7)

Should have been fixed by Bug 1673669

This fix should also be in the 84.0rc1 build for users to test.

Assignee: nobody → mak

Marking as verified as per https://bugzilla.mozilla.org/show_bug.cgi?id=1673669#c31 on:
84.0 RC1 - 2020-12-07 on Windows 10 and Mac 10.14.6

I'll come back with verification update for 84 on Ubuntu and verifying the fix for 85.

Flags: needinfo?(adrian.florinescu)

Verified on Ubuntu 18.04 64-bit using Firefox 85 beta 3 and latest Nightly 86.0a1.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(adrian.florinescu)

Hello is this fixed? Currently using version 86 but when I press enter while having my cursor on the last character it still gives me google search result.

(In reply to David from comment #11)

Hello is this fixed? Currently using version 86 but when I press enter while having my cursor on the last character it still gives me google search result.

Which IME are you using and what are your STR? I tested this on Windows with Nalgaeset (from comment 0) with these STR:

  1. Switch the IME to qwerty mode
  2. Type @bing
  3. Switch to Hangul mode
  4. Type 하나
  5. Verify that the selected row is "하 - Search with Bing"
  6. Press enter
  7. Verify that Bing loads with 하나

It doesn't matter whether I type the trailing space in step 2 in qwerty or Hangul mode.

Flags: needinfo?(hj.park)

(In reply to Drew Willcoxon :adw from comment #12)

(In reply to David from comment #11)

Hello is this fixed? Currently using version 86 but when I press enter while having my cursor on the last character it still gives me google search result.

Which IME are you using and what are your STR? I tested this on Windows with Nalgaeset (from comment 0) with these STR:

  1. Switch the IME to qwerty mode
  2. Type @bing
  3. Switch to Hangul mode
  4. Type 하나
  5. Verify that the selected row is "하 - Search with Bing"
  6. Press enter
  7. Verify that Bing loads with 하나

It doesn't matter whether I type the trailing space in step 2 in qwerty or Hangul mode.

Okay, for my case, I can confirm this happens when I am using Private Window.
Also I am using a bookmark keyword search with Korean IME:

  1. Create a bookmark with a ketword d: https://dict.naver.com/search.nhn?dicQuery=%s.
  2. Type d 한글 in a Private Window, press enter while the keyboard cursor is on `글'.
  3. Results in google search https://www.google.com/search?client=firefox-b-d&q=d+%ED%95%9C%EA%B8%80 instead of https://dict.naver.com/search.nhn?dicQuery=%ED%95%9C%EA%B8%80.

I get the expected behaviour with Private Window when I type d 한글 followed by Left Key before pressing enter.
Tested on Firefox 86

Flags: needinfo?(hj.park)

Sorry it is Right Key in the above reply.

See Also: → 1696022

Thanks, I can reproduce that. It's a separate problem so I filed bug 1696022, but I think you might have previously reported this in bug 1678963, but we didn't understand it well at the time.

Thanks for the update. Also sorry I posted here because my original report (bug 1678963) was marked as duplicate of this issue so I thought this is the right place to ask the question.

No problem, I just wanted to acknowledge that you reported it earlier and it shouldn't have necessarily been closed, but we didn't know that at the time.

You need to log in before you can comment on or make changes to this bug.