Open Bug 1678702 Opened 2 years ago Updated 3 months ago

Slider animation is not smooth on https://nos.nl/

Categories

(Core :: CSS Transitions and Animations, defect)

Desktop
Unspecified
defect

Tracking

()

REOPENED
Webcompat Priority P2
Tracking Status
firefox-esr78 --- unaffected
firefox83 --- wontfix
firefox84 --- wontfix
firefox85 --- wontfix
firefox86 --- disabled
firefox87 --- disabled

People

(Reporter: ksenia, Unassigned)

References

(Blocks 1 open bug, Regression, )

Details

(Keywords: regression)

As reported in https://github.com/webcompat/web-bugs/issues/62037

STR:

  1. Visit https://nos.nl/ in Nightly 85.0a1 (2020-11-20) on desktop
  2. Scroll down to "Nieuws in beeld 10 foto's" gallery and click on the red arrow to see the couple next photos

Expected:
Slides change smoothly

Actual:
Slides don't animate

From mozregression:

10:48.93 INFO: Narrowed integration regression window from [4039bc28, 20d40fcc] (4 builds) to [5099104e, 20d40fcc] (2 builds) (~1 steps left)
10:48.93 INFO: No more integration revisions, bisection finished.
10:48.93 INFO: Last good revision: 5099104ea5ee71d7069c797542e08895307affed
10:48.93 INFO: First bad revision: 20d40fcc3f751c7a7517fb691dc4e611872f2d76
10:48.93 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=5099104ea5ee71d7069c797542e08895307affed&tochange=20d40fcc3f751c7a7517fb691dc4e611872f2d76

This appears to be a paid plugin called Royal Slider, similar behavior is reproducible on https://dimsemenov.com/plugins/royal-slider/gallery/

Hi Hiroyuki, would you be able to take a look at this?

Flags: needinfo?(hikezoe.birchill)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1679649

No, that one is caused by a different problem. I am still investigating this, haven't found where the underlying problem is, but anyway, this case is caused by overflow: visible transform offset from the reference frame, and the overflowed area is offset-ed side.

Status: RESOLVED → REOPENED
Flags: needinfo?(hikezoe.birchill)
Resolution: DUPLICATE → ---

The severity field is not set for this bug.
:hiro, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(hikezoe.birchill)
Severity: -- → S3
Flags: needinfo?(hikezoe.birchill)
Version: Firefox 85 → Trunk
Webcompat Priority: --- → ?
Has Regression Range: --- → yes

The gallery from the reported site is now gone, an the second linked webcompat issue is not reproducible anymore.
I came across one more report with adobe.com that seems to be related to this issue. Setting layout.animation.prerender.partial to false makes animation work.

:hiro, given this appears to now affect adobe.com, can you take a second look at this and see if the priority should be raised? This is still Nightly-only, but it would be good to have a look anyway.

Webcompat Priority: ? → P2
Flags: needinfo?(hikezoe.birchill)
Depends on: 1760918

I am going to disable the feature, partial pre-render, on all channels in bug 1760918.

Flags: needinfo?(hikezoe.birchill)
You need to log in before you can comment on or make changes to this bug.