Closed Bug 1679998 Opened 1 year ago Closed 1 year ago

Add Apple Silicon to the WebRender allowlist

Categories

(Core :: Graphics: WebRender, task, P3)

ARM64
macOS
task

Tracking

()

RESOLVED FIXED
85 Branch
Tracking Status
firefox85 --- fixed

People

(Reporter: aosmond, Assigned: aosmond)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Apple Silicon has a new GPU vendor ID, Apple / 0x106b from the crash reports. We do not appear to get a device ID oddly enough.

Attachment #9190524 - Attachment description: Bug 1679998 - Part 1. Add Apple as a GPU vendor and OSX 11.1 to the gfx blocklist. → Bug 1679998 - Part 1. Add Apple as a GPU vendor to GfxInfo.
Pushed by aosmond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a8e4f0811dad
Part 1. Add Apple as a GPU vendor to GfxInfo. r=jrmuizel,mstange
https://hg.mozilla.org/integration/autoland/rev/59acb4646d06
Part 2. Add Apple GPUs to the WebRender allowlist. r=jrmuizel
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch
Duplicate of this bug: 1680200
You need to log in before you can comment on or make changes to this bug.