Closed Bug 1681301 Opened 9 months ago Closed 9 months ago

[Apple Chip - ARM64 M1] [pinterest.com] Severe performance issues upon scrolling on pinterest with video playback

Categories

(Core :: Graphics, defect)

ARM64
macOS
defect

Tracking

()

VERIFIED FIXED
85 Branch
Tracking Status
firefox83 --- wontfix
firefox84 --- wontfix
firefox85 --- verified

People

(Reporter: tbabos, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(2 files)

Affected Versions:
84.0 - Beta RC
83.0 - Release - works with Rosetta installed

Unaffected Version:
Nightly (2020-12-08)

Affected Platforms:
ARM64 MacOS:

  • miniMac: MacOS Big Sur 11.0.1, Mac mini (M1, 2020), Chip: Apple M1, display 27-inch (2560x1440), with Rosetta

Unaffected Tested Platforms:
MacOS 10.15 MacBook Pro 13inch, macOS Big Sur 11 (intel chip)

Steps to reproduce:

  1. Go to https://ro.pinterest.com/pin/584342120393644748/ (log in when prompted)(make sure the browser is maximized)
  2. While the video is played back start scrolling up and down
  3. Reload the page once if needed (performance issues are not visible enough)
  4. Start scrolling again and also check the hover highlight from the address bar search options for significant delays or open new tabs

Expected Results:
Scrolling on Pinterest while videos are played back should be smooth

Actual Result:
Severe performance issues can be observed if a video is played back while scrolling on Pinterest and the suggested images are being loaded. See recording: https://streamable.com/eymtu5

Severity suggestion: S1 - S2 - Pinterest is a common top site
Not reproducible with Chrome using the same M1 device. Chrome nearly hits 25% CPU usage while Firefox can reach over 100% (please note macOS CPU usage shown in activity monitor is per core). Attached screenshots of core usage in Beta and Nightly (unaffected)

The significant difference in Nightly (where this is not reproducible) is that it uses WebRender while on Beta and Release we have OpenGL.

Performance Profile: https://profiler.firefox.com/from-addon/calltree/?globalTrackOrder=7-0-1-2-3-4-5-6&hiddenGlobalTracks=1-2-3-4-5&hiddenLocalTracksByPid=1148-1-2-3~1780-0-1-2-3-4-5&localTrackOrderByPid=1148-4-0-1-2-3~1780-6-0-1-2-3-4-5~&thread=10&v=5

Attached image Nightly Core Usage.png
Attached image Beta Core Usage.png

The difference appears to be caused by WebRender not being enabled on arm64 Beta builds. Bug 1679998 enabled WebRender on Apple arm64 hardware and is in 85.

@Timea, could you verify that the problem is not reproducible for you with on Beta after setting gfx.webrender.all=true in about:config and restarting?

Flags: needinfo?(timea.babos)

@mstange and @RyanVM, uplifting enabling WebRender (bug 1679998) is something to consider for an RC2.

Flags: needinfo?(ryanvm)
Flags: needinfo?(mstange.moz)

That seems like a pretty massive change to make in an RC build...

Flags: needinfo?(ryanvm)
Flags: needinfo?(mstange.moz)

I agree, I would prefer sitting this one out. Firefox 82 would probably have had the same bad performance on all macOS variants (because it didn't have WR enabled anywhere).

Sounds like we should call this fixed by bug 1679998 in any case.

Status: NEW → RESOLVED
Closed: 9 months ago
Depends on: 1679998
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch

Can confirm that enabling WebRender on Beta 84.0 RC does indeed fix this issue as it can also be observed on Nightly.

Flags: needinfo?(timea.babos)
Status: RESOLVED → VERIFIED

A severity wasn't assigned for this bug. Jim/Haik, could you please help?

Flags: needinfo?(jmathies)
Severity: -- → S3
Flags: needinfo?(jmathies)
You need to log in before you can comment on or make changes to this bug.