Closed Bug 1680569 Opened 5 months ago Closed 5 months ago

Mac: Homebrew version of rustc 1.47.0 contains mismatched tools (cargo 1.46.0 is too old)

Categories

(Firefox Build System :: Toolchains, defect)

defect

Tracking

(Not tracked)

VERIFIED WONTFIX

People

(Reporter: standard8, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

Updating to the latest mozilla-central on Mac and trying to build, I'm getting:

 0:05.96 checking rustc version... 1.47.0
 0:05.97 checking cargo version... 1.46.0
 0:05.97 ERROR: Cargo package manager 1.46.0 is too old.
 0:05.97 To compile Rust language sources please install at least
 0:05.97 version 1.47.0 of 'cargo' and make sure it is first in your path.
 0:05.98 You can verify this by typing 'cargo --version'.

On further investigation this is due to a homebrew issue, the formula for 1.47.0 is shipping cargo 1.46.0 for some reason:

https://github.com/Homebrew/homebrew-core/issues/63202

There is work in progress to release a 1.48.0 version of cargo, though that currently looks blocked on some rust build issues. Maybe there's someone that can help them out?

In any case, since this is going to affect developers, I'm filing it here so it can block mach-busted so that the details can be found more easily.

The recommended way to install rust is to use rustup. That's what mach bootstrap does.

No longer blocks: mach-busted
Blocks: mach-busted
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → WONTFIX

Heads up that ./mach bootstrap should install rustup and ensure that cargo is up-to-date, unless you've adjusted your local config manually to use brew's rust instead.

Thanks, I probably had that setup via brew from the early days when rust wasn't in bootstrap or something like that. Removing it and then running bootstrap worked.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.