Closed Bug 1681230 Opened 11 months ago Closed 10 months ago

[Wayland] URL partially obscured in urlbar when length exceeds available space

Categories

(Core :: Graphics: WebRender, defect)

Unspecified
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1681244
Tracking Status
firefox85 --- affected

People

(Reporter: kevin, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Using current Nightly with MOZ_ENABLE_WAYLAND=1 on Sway with Intel graphics, when the URL displayed in the address bar is longer than the available space, it often becomes obscured and unreadable in places which should be visible in the address bar. The obstruction is inconsistent and changes as the mouse moves near the address bar. The best reproduction I've found is to paste a long URL, such as the one below, into the address bar and press Alt+Enter to open in a new tab (this seems to cause the issue more frequently than opening it in the current tab).

https://addons.mozilla.org/en-US/firefox/search/?q=example&platform=Linux&appver=85.0a1&utm_source=firefox-browser&utm_medium=firefox-browser&utm_content=addons-manager-search

The result is shown in the attached screenshot.

When running without MOZ_ENABLE_WAYLAND, the same URL obscuring occurs very briefly when the tab is opened, but disappears almost immediately. With MOZ_ENABLE_WAYLAND, the obscuring is persistent.

mozregression:
Last good revision: a0b52f4d44f2f583fb6a8033c47973737f713bb8
First bad revision: 1297d9265f7223e573536af9f3e5adbe79beec25
Pushlog: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=a0b52f4d44f2f583fb6a8033c47973737f713bb8&tochange=1297d9265f7223e573536af9f3e5adbe79beec25

Possibly regressed by Bug 1676559.

Blocks: wayland

Duplicate of Bug 1681244 (although this one was opened first, since all the discussion and fixing happened on that one, I'm closing this one).

Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1681244
You need to log in before you can comment on or make changes to this bug.