If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

no text input on date birth field

VERIFIED DUPLICATE of bug 154690

Status

Tech Evangelism Graveyard
English Other
VERIFIED DUPLICATE of bug 154690
15 years ago
3 years ago

People

(Reporter: jeremy ekers, Assigned: Tristan Nitot)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

In javascript console, get following error:
--------error message starts--------------
Error: event is not defined
Source File:
https://welcome3.smile.co.uk/servlet/SmileEnrolment?&CurrentPage=ExistingCustomer#
Line: 1
--------error message ends--------------

other elements on form are ok (ie tick boxes).


Reproducible: Always

Steps to Reproduce:
1.go to url above
2.select date of birth field with mouse
3.try to type a number

Actual Results:  
no number appeared

Expected Results:  
number should appear

In case the url doesnt work, i went to http://www.smile.co.uk, selected current
account from LHS, then follow `apply now' entries
(Reporter)

Comment 1

15 years ago
Also happens on linux: mozilla:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

Comment 2

15 years ago
I also see this on Linux - Moz1.2alpha, 2002091016.

In fact, it gets worse. I opened that site in a tab; when I closed the tab,
Mozilla crashed. Talkback IDs:
TB10830744Y
TB10830668Z

When I clicked a text field, no caret appeared; when I tried to type anything, I
got beeps and status bar messages about Type Ahead Find.

Reporter: please change Platform & OS to All/All. I don't think this should be
'Form Submission' either, but I'm not sure what it should be.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

15 years ago
OS: Windows 2000 → All
Hardware: PC → All

Comment 3

15 years ago
if(document.layers){
       window.captureEvents(Event.MOUSEDOWN);
       window.onmousedown = function(e){if(e.target==document){return false;}};
             
}
else {
    document.onmousedown = function(){return false;}
}

onmousedown is disabled so the click never gets to the input and therefore it
does not get focus. You can still tab to the field and enter data.

This is evangelism.
Assignee: alexsavulov → momoi
Component: Form Submission → English: Non-US
Product: Browser → Tech Evangelism
QA Contact: vladimire → jeesun
Version: other → unspecified

Comment 4

15 years ago
Uk site, moving to Europe: West - possible dupe of bug 154690 which is to do
with general javascript problems.
Assignee: momoi → nitot
Component: English: Non-US → Europe: West
QA Contact: jeesun → brantgurganus2001

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 154690 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 6

15 years ago
v
Status: RESOLVED → VERIFIED

Comment 7

15 years ago
tech evang june 2003 reorg
Component: Europe: West → English Other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.