Closed Bug 1682162 Opened 4 months ago Closed 1 month ago

Print margin unit should be localized

Categories

(Toolkit :: Printing, defect, P3)

Desktop
Windows 10
defect

Tracking

()

RESOLVED FIXED
88 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox83 --- unaffected
firefox84 --- wontfix
firefox85 --- wontfix
firefox86 --- wontfix
firefox87 --- wontfix
firefox88 --- fixed

People

(Reporter: alice0775, Assigned: sfoster)

References

Details

(Keywords: parity-chrome, regression, Whiteboard: [print2020_v88] )

Attachments

(2 files)

Margin unit is fixed in "inch". But the Margin unit should be localized.

STR:
Ctrl+P > more settings > Margins > select Custom (inches)

Actual results:
Margin unit is fixed in "inch"

Expected results:
Margin unit should be in "mm" in Ja locale. Firefox83 and Chromium works as expected.

Whiteboard: [print2020_v86]
Duplicate of this bug: 1682334
Keywords: regression

We've never supported mm so I don't think this is a regression.

Severity: -- → N/A
Type: defect → enhancement
Keywords: regression
Priority: -- → P3
Attached image screenshot evidence

(In reply to Mark Striemer [:mstriemer] from comment #2)

We've never supported mm so I don't think this is a regression.

No.
Old print setup dialog supported "mm" in Firefox83 on Windows10 japanese locale/languages.

This is definitely regression from New Tab modal Print Preview.

Type: enhancement → defect

Oh interesting, I didn't realise that. Thanks!

Keywords: regression
Severity: N/A → --
Assignee: nobody → sfoster
Status: NEW → ASSIGNED
Whiteboard: [print2020_v86] → [print2020_v88]
See Also: → 1689360
Duplicate of this bug: 1689360
Duplicate of this bug: 1694706

Can we get an update on this?

Flags: needinfo?(sfoster)

I have a WIP patch that addresses this. It is on the back-burner for now as I have other higher-priority tasks I'm afraid. The patch exposes an existing bug we have where its possible to get an undefined paper object when we try to assemble the preset margin values. I don't think its too much work to resolve those issues and get this back in for review, and I hope to get back to it soon.

Flags: needinfo?(sfoster)
Pushed by sfoster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3db292778c46
Use the paperSizeUnit to display and handle mm/inch custom margin values. r=emalysz,fluent-reviewers,flod
Regressions: 1698240
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch

I apologise for not being sufficiently technical to understand the code in this update, but does it mean that a fix has been found and implemented? I have Firefox 86.0.1 (updated 15 minutes ago) and I am still unable to set custom print margins in mm despite print_paper_size_unit being set to 1.

I have Firefox 86.0.1 (updated 15 minutes ago) and I am still unable to set custom print margins in mm despite print_paper_size_unit being set to 1.

The change landed in the development branch of Firefox two hours ago. This means that you can see this in the next build of Firefox Nightly or in Firefox Beta once Firefox 88 hits the Beta channel or in the stable release of Firefox 88 once released ("Target Milestone: --- → 88 Branch").

Thank you. I will check this again once I have received Firefox 88 and, if it helps, report back.

May I say that I am both impressed with and appreciative of the excellent communications from the Bugzilla team to keep me informed of progress with this issue.

See Also: → 1698254
You need to log in before you can comment on or make changes to this bug.