Closed Bug 1682393 Opened 3 months ago Closed 1 month ago

Show origin to tabmodal alert/confirm/prompt dialogs

Categories

(Firefox :: General, enhancement)

Desktop
All
enhancement

Tracking

()

RESOLVED FIXED
86 Branch
Tracking Status
firefox86 --- fixed

People

(Reporter: Gijs, Assigned: mtigley)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Whiteboard: [proton-modals])

Attachments

(1 file)

We should display the origin inside the dialog.

Whiteboard: [proton-modals]

This looks like it will be fixed by Bug 1680637 once it lands.

Depends on: 1680637
Assignee: nobody → mtigley
Status: NEW → ASSIGNED

(In reply to Micah Tigley [:mtigley] from comment #1)

This looks like it will be fixed by Bug 1680637 once it lands.

The origin text appears on macos, but not on Windows so we'll need to continue investigating this

Summary: Add origin to tabmodal alert/confirm/prompt dialogs → Show origin to tabmodal alert/confirm/prompt dialogs on Windows
Summary: Show origin to tabmodal alert/confirm/prompt dialogs on Windows → Show origin to tabmodal alert/confirm/prompt dialogs
Attachment #9197547 - Attachment description: Bug 1682393 - Show origin to tabmodal alert/confirm/prompt dialogs. → Bug 1682393 - Show origin for tabmodal alert/confirm/prompt dialogs.
Pushed by mtigley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8ef2ff6e404d
Show origin for tabmodal alert/confirm/prompt dialogs. r=Gijs

The change we introduced in https://phabricator.services.mozilla.com/D102077 will also show the origin title for the old modals and tests in tab_modal_prompts.html are catching this.

Since showing the title is specifically for the new modal dialogs, I think we should add a check for the prompts. contentPromptSubDialog when we hide #infoTitle.

Flags: needinfo?(mtigley)
Pushed by mtigley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cc07576670e7
Show origin for tabmodal alert/confirm/prompt dialogs. r=Gijs
Flags: needinfo?(mtigley)

(In reply to Dorel Luca [:dluca] from comment #8)

Backed out changeset cc07576670e7 (bug 1682393) for Browser-chrome in browser/base/content/test/tabdialogs/browser_tabdialogbox_content_prompts.js. CLOSED TREE

That's odd, a push to tryserver I made earlier didn't seem to catch this on Linux: https://treeherder.mozilla.org/jobs?repo=try&revision=34c8fc6fcc7cc6d7b22196a48c4e33cb4724224a . I'll investigate tomorrow.

Flags: needinfo?(mtigley)

(In reply to Micah Tigley [:mtigley] from comment #9)

(In reply to Dorel Luca [:dluca] from comment #8)

Backed out changeset cc07576670e7 (bug 1682393) for Browser-chrome in browser/base/content/test/tabdialogs/browser_tabdialogbox_content_prompts.js. CLOSED TREE

That's odd, a push to tryserver I made earlier didn't seem to catch this on Linux: https://treeherder.mozilla.org/jobs?repo=try&revision=34c8fc6fcc7cc6d7b22196a48c4e33cb4724224a . I'll investigate tomorrow.

Looks like it's failing only on tsan, which wasn't in your trypush. In all the time I've worked fulltime on Mozilla stuff, this is the first tsan-only failure caused by a frontend patch that I've seen, so don't lose any sleep over it. It's pretty odd... given that this isn't really a low-level/C++ change.

Failure message:

TEST-UNEXPECTED-FAIL | browser/base/content/test/tabdialogs/browser_tabdialogbox_content_prompts.js | Uncaught exception - at chrome://mochitests/content/browser/browser/base/content/test/tabdialogs/browser_tabdialogbox_content_prompts.js:62 - TypeError: can't access property "_dialogReady", dialog is undefined

I'm guessing there's some kind of race condition - tsan builds are slow. I'm guessing using:

let dialogShown = BrowserTestUtils.waitForEvent(gBrowser, "DOMWillOpenModalDialog");

before creating the tab, and then

await dialogShown

before running let dialog = contentPromptManager._dialogs[0]; would fix this. This isn't hitting the previous test because it opens the dialog directly/synchronously from within the parent process.

Pushed by mtigley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/397e268c52fd
Show origin for tabmodal alert/confirm/prompt dialogs. r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 86 Branch
Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/0c06805c3f6b
Port bug 1682393 - Add pref prompts.contentPromptSubDialog to all-thunderbird.js. rs=bustage-fix
Regressions: 1689420
No longer regressions: 1689420
Depends on: 1694882
You need to log in before you can comment on or make changes to this bug.