Closed Bug 1682764 Opened 6 months ago Closed 5 months ago

SQL syntax error when expiring `try` data

Categories

(Tree Management :: Perfherder, defect, P1)

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: igoldan, Assigned: igoldan)

References

Details

Attachments

(1 file)

Seems like there's a bug with expiring try data. The error is as follows:

    WARNING [treeherder.model.management.commands.cycle_data:117] No data cycling could be performed. (Reason: (1064, "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')\n LIMIT 100' at line 2"))

Looking closer into what caused this, it seems this is the problematic SQL query:

    DELETE FROM `performance_datum`
    WHERE repository_id = %s AND push_timestamp <= %s AND ()
    LIMIT %s

with the AND () being the invalid portion.

Note: this is only happening when there aren't any signatures associated with the try repository. In normal circumstances, this should never happen.

This bug only reproduces on the treeherder-prototype2 environment, because it's not ingesting any try data (in order to keep its disk usage to a minimum).
Jira link: https://jira.mozilla.com/browse/FXP-1391

Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
See Also: → 1653227
Duplicate of this bug: 1653227
You need to log in before you can comment on or make changes to this bug.