Closed Bug 1683165 Opened 10 months ago Closed 2 months ago

Add a pref that allows users to disable all automated anti-tracking webcompat heuristics and skiplists

Categories

(Core :: Privacy: Anti-Tracking, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
93 Branch
Tracking Status
firefox93 --- fixed

People

(Reporter: englehardt, Assigned: pbz)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files, 1 obsolete file)

We often face a tradeoff between uncompromising privacy features and web compatibility. To get sites working under stricter defaults, we've landed on the general approach of trying to detect the user's intent and automatically relaxing protections when we think the user is trying to achieve something that tracking protection would otherwise break.

This is great for most users, but there are certainly powerusers that would prefer Firefox to never unblock tracking without their explicit approval. It would be great to give these users a checkbox

Here are examples:

  • The cookie blocking heuristics
  • The 5 automatic grants when requestStorageAccess is called.
  • dFPI's automatic grants (not documented yet)
  • Content blocking script shimming's automatic relaxation of Facebook script blocking when a user interacts with a Facebook login button

Ideally all of these get tied to a single pref that's then controlled by a checkbox in the Custom mode of ETP. The checkbox should be default-on.

For the storage access API we also have dom.storage_access.auto_grants and dom.storage_access.max_concurrent_auto_grants which can help.

See Also: → 1644273
Blocks: 1687942
See Also: → 1695054
Blocks: tp-shim
No longer blocks: 1687942
Assignee: nobody → pbz
Status: NEW → ASSIGNED
Attachment #9237936 - Attachment description: Bug 1683165 - Add a pref to disable anti-tracking webcompat features. r=timhuang,johannh → Bug 1683165 - Add a pref to control anti-tracking webcompat features. r=timhuang,johannh
Pushed by pzuhlcke@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e5483fd469ab
Add a pref to control anti-tracking webcompat features. r=timhuang,twisniewski,webcompat-reviewers,dimi
https://hg.mozilla.org/integration/autoland/rev/10c2109adc3f
Updated tests for the anti-tracking webcompat pref. r=timhuang
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch
Blocks: 1728110
Summary: Add a checkbox to ETP Custom that allows users to disable all automated webcompat heuristics → Add a pref that allows users to disable all automated anti-tracking webcompat heuristics and skiplists

Comment on attachment 9238027 [details]
Bug 1683165 - UI for the anti-tracking webcompat pref in about:preferences#privacy. r=johannh,timhuang

Revision D123663 was moved to bug 1728110. Setting attachment 9238027 [details] to obsolete.

Attachment #9238027 - Attachment is obsolete: true
Duplicate of this bug: 1644273
You need to log in before you can comment on or make changes to this bug.