Closed Bug 1684528 Opened 7 months ago Closed 6 months ago

Cannot set fixed default bookmark folder any more

Categories

(Firefox :: Bookmarks & History, defect)

Firefox 85
defect

Tracking

()

RESOLVED DUPLICATE of bug 1412263

People

(Reporter: post+mozilla, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:85.0) Gecko/20100101 Firefox/85.0

Steps to reproduce:

In past versions of Firefox, all new bookmarks were added in the same folder -- "Other Bookmarks". This behavior was recently changed in https://bugzilla.mozilla.org/show_bug.cgi?id=1665389, but the change is larger than the bug description indicates: not only the default was changed, but Firefox now remembers the last bookmark folder used, and uses it again for the next bookmark.

I think this is a bad idea. There is no reason to assume that the new bookmark has much to do with the previous one, and indeed I have put multiple bookmarks into completely wrong folders due to this change in behavior.

I tried setting browser.bookmarks.defaultLocation to "unfiled", which works exactly once, but when I change the bookmark folder on one bookmark it still also changes the default for other, new bookmarks. So currently there seems to be no way to have all new bookmarks appear in the same, consistent folder, which IMO is a regression compared to earlier versions of Firefox.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Bookmarks & History

Looking it is something from https://bugzilla.mozilla.org/show_bug.cgi?id=1412263

As now I cannot pick a default folder as every time I change the folder the next is remembering. I am losting my bookmarks because it saves in the wrong folder -.-'

So bug 1412263 is indeed a potential solution to this problem, so just duping there.

Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1412263
You need to log in before you can comment on or make changes to this bug.