Closed Bug 1685606 Opened 1 year ago Closed 10 months ago

Link to SeaMonkey website in debugQA for verification sites and link to other pages in the website's development section

Categories

(SeaMonkey :: General, task)

Tracking

(seamonkey2.53+ fixed)

RESOLVED FIXED
seamonkey 2.89
Tracking Status
seamonkey2.53 + fixed

People

(Reporter: iannbugzilla, Assigned: iannbugzilla)

References

(Blocks 1 open bug)

Details

(Whiteboard: SM2.53.9)

Attachments

(2 files, 1 obsolete file)

See bug 1685603 for more details.
The patches here cover the work on the debugQA code.

Summary: Link to SeaMonkey website in debugQA for verification sites and link to other pages of website's development section → Link to SeaMonkey website in debugQA for verification sites and link to other pages in the website's development section

WIP patch - need feedback on naming and position of the new links
Are there other menu items which would work better on the website?

Attachment #9195958 - Flags: feedback?(frgrahl)
Blocks: 1684962

Moving to r? from f?

Attachment #9195958 - Attachment is obsolete: true
Attachment #9195958 - Flags: feedback?(frgrahl)
Attachment #9233009 - Flags: review?(frgrahl)
Attachment #9233009 - Flags: approval-comm-release?
Attachment #9233009 - Flags: approval-comm-esr60?

Comment on attachment 9233009 [details] [diff] [review]
1685606-deqbugqa-www-2539.patch

LGTM

For later discussion I am not sure about keeping "Useful Sites" separate:
<menuitem label="Useful Sites"

Maybe merge/rename it with "Verification" if we don't find more sites. For now ok with me.

Attachment #9233009 - Flags: review?(frgrahl)
Attachment #9233009 - Flags: review+
Attachment #9233009 - Flags: approval-comm-release?
Attachment #9233009 - Flags: approval-comm-release+
Attachment #9233009 - Flags: approval-comm-esr60?
Attachment #9233009 - Flags: approval-comm-esr60+

Follow up as discussed. Remove link to outdated nightly builds and add Bills site. Also add esr91 becuase esr78 will be obsolete soon. Can go into its own bug if desired.

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: Outdated information.
Testing completed (on m-c, etc.): 2.53.9b1 pre
Risk to taking this patch (and alternatives if risky): trivial
String changes made by this patch: --

Attachment #9234166 - Flags: review?(iann_bugzilla)
Attachment #9234166 - Flags: approval-comm-release?
Attachment #9234166 - Flags: approval-comm-esr60?
Comment on attachment 9234166 [details] [diff] [review]
1685606-buildssource-2539.patch

>-        <menuitem label="Nightly Builds"
>-                  oncommand="openQAUrl('https://www.seamonkey-project.org/dev/nightly');"/>
>+        <menuitem label="Daily unofficial 2.53 Builds"
>+                  oncommand="openQAUrl('https://www.wg9s.com/comm-253/');"/>
>+        <menuitem label="Daily unofficial 2.57 Builds"
>+                  oncommand="openQAUrl('https://www.wg9s.com/comm-257/');"/>
Should these be in a similar order to the first group, so 2.57 before 2.53?

r/a=me with that answered / addressed.
Attachment #9234166 - Flags: review?(iann_bugzilla)
Attachment #9234166 - Flags: review+
Attachment #9234166 - Flags: approval-comm-release?
Attachment #9234166 - Flags: approval-comm-release+
Attachment #9234166 - Flags: approval-comm-esr60?
Attachment #9234166 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/06d8bcb8fca8
Link to SeaMonkey website in debugQA for verification sites and link to other pages in the website's development section. r=frg
https://hg.mozilla.org/comm-central/rev/2e261fde2c40
Link to unofficial builds instead of outdated nightlies and add esr 91 checkins. r=IanN

Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED

Should these be in a similar order to the first group, so 2.57 before 2.53?

Yes makes sense. Fixed for checkin.

Whiteboard: SM2.53.9
Target Milestone: --- → seamonkey 2.89
Duplicate of this bug: 1718671

https://gitlab.com/seamonkey-project/seamonkey-2.53-comm/-/commit/0202cf44349a0e77bd15168bb94f8e41a9d6b086
Link to SeaMonkey website in debugQA for verification sites and link to other pages in the website's development section. r=frg a=frg
https://gitlab.com/seamonkey-project/seamonkey-2.53-comm/-/commit/2291b950471757dbb674451312016405e747ed9d
Link to unofficial builds instead of outdated nightlies and add esr 91 checkins. r=IanN a=IanN

Blocks: 1746790
You need to log in before you can comment on or make changes to this bug.