Closed Bug 1685780 Opened 2 years ago Closed 2 years ago

process hang on startup (UI shown, bookmarks toolbar shown but not populated yet)

Categories

(Firefox :: Untriaged, defect)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: aryx, Unassigned)

References

Details

Attachments

(2 files)

Firefox 86.0a1 on Windows 8.1

One Nightly profile always hangs on startup. The UI is shown (tab bar, location bar etc.). The bookmarks bar is shown as empty, the content area is just grey.

Nightly becomes unresponsive and I terminate it by clicking at the 'X' button to close, get a prompt it's not responding and confirm its termination. The issue persists when it gets launched again but sometimes during investigation it went back to normal (e.g. sometimes when the profile got copied to a different location and launched, sometimes when launched in safe mode).

I wasn't able to get useful information out of Process Monitor because I don't know which process is affected. The initial process exits very quickly.

Doug, does this sound like the "startup skeleton" you posted about on dev-platform?

Flags: needinfo?(dothayer)

Is this what it looks like? https://i.imgur.com/R4ynXW5.png

Flags: needinfo?(aryx.bugmail)

Firefox: untriaged is probably a better component for a bug where the underlying issue is unknown.

Component: General → Untriaged
Product: Core → Firefox

If it's on Windows 8 then no it can't be the skeleton UI.

Flags: needinfo?(dothayer)

Hi Sebastian,

Can you attach your about:support information?
Best,
Clara

Flags: needinfo?(aryx.bugmail)

I've been getting that "startup skeleton" UI for about 2 seconds during startup on any profile. (e.g. not like the one in Sebastian's image, but the image linked above) Starting like last week. It applies the lightweight color theme but other than that looks identical to this image. Anyone have a link to more information about that so I can get a sense of what I should report? Thanks

FYI this startup skeleton thing goes away if I start in safe mode or manually disable hardware acceleration.

ok I can say unequivocally that setting browser.startup.preXulSkeletonUI = false fixes it. alternatively, leaving that true but setting browser.startup.blankWindow = false also fixes it. the downside is that the window does not immediately open when starting up firefox with a lot of extensions and user modifications. i guess that's the purpose of this feature, and it doesn't look so ugly if the user hasn't modified the UI much. it's weird though because i never noticed this until like... 8 or 9 nightly updates ago. definitely didn't change any of those prefs before now. so i guess something else is slowing down the loading of documents.

aminomancer: Please create a new bug in Toolkit :: Startup and Profile. Thank you in advance.

Sebastian, can you provide any additional step? Did this start happening after updating firefox?

(Wondering if it's related to https://bugzilla.mozilla.org/show_bug.cgi?id=1686708)
Best,
Clara

Flags: needinfo?(aryx.bugmail)

I'm following up on my last message.
Bug 1686708 is being handled so hopefully this will get fixed as well.
Best,
Clara

Issue doesn't reproduce anymore. Bug 1686708 is unrelated.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(aryx.bugmail)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.