Closed Bug 1686229 Opened 8 months ago Closed 8 months ago

Record blocked modules in third-party module ping

Categories

(Firefox :: Launcher Process, enhancement)

Unspecified
Windows
enhancement

Tracking

()

RESOLVED FIXED
86 Branch
Tracking Status
firefox86 --- fixed

People

(Reporter: toshi, Assigned: toshi)

References

(Blocks 1 open bug)

Details

Attachments

(5 files)

Currently we don't record the third-party modules ping if a module was blocked. It's good to record blocked modules as well so that we can assess the impact of our blocklist. We should also show blocked modules on the third-party modules section on about:support.

Attachment #9197978 - Flags: data-review?(chutten)

We used to record a DLL loading event only when a module was loaded.
With this patch, we record an event for a module blocked by our DLL
blocklist as well as a loaded module. It is achieved by calling
to ModuleLoadFrame::NotifySectionMap in patched_NtMapViewOfSection
regardless of the block action.

This patch introduces a new member ModuleLoadInfo::mStatus and
ProcessedModuleLoadEvent::mLoadStatus to keep the DLL loading status,
which will be added to the third-party-modules ping by a following patch.

This patch adds a new field "loadStatus" to the third-party-modules ping,
which derives from ProcessedModuleLoadEvent::mLoadStatus introduced by
the earlier patch.

Depends on D102407

This patch displays the new telemetry field "loadStatus", which was introduced
by the earlier patch, on about:support. With this information, a user can see
each of injected modules was really loaded or blocked by our DLL blocklist.

Depends on D102408

Comment on attachment 9197978 [details]
data-review-request-for-bug1686229.txt

DATA COLLECTION REVIEW RESPONSE:

Is there or will there be documentation that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes.

Is there a control mechanism that allows the user to turn the data collection on and off?

Yes. This collection is Telemetry so can be controlled through Firefox's Preferences.

If the request is for permanent data collection, is there someone who will monitor the data over time?

Yes, Toshihito Kikuchi is responsible.

Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 1, Technical.

Is the data collection request for default-on or default-off?

Default on for all channels.

Does the instrumentation include the addition of any new identifiers?

No.

Is the data collection covered by the existing Firefox privacy notice?

Yes.

Does there need to be a check-in in the future to determine whether to renew the data?

No. This collection is permanent.


Result: datareview+

Attachment #9197978 - Flags: data-review?(chutten) → data-review+
Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1878295822f4
Part1. Add a member to ModuleLoadInfo to indicate the status of DLL load.  r=mhowell
https://hg.mozilla.org/integration/autoland/rev/a839d56cb678
Part2. Add the loadStatus field to the third-party-modules ping.  r=chutten
https://hg.mozilla.org/integration/autoland/rev/f8a9c1efddec
Part3. Display a module's loading status on about:support.  r=Gijs,fluent-reviewers
Backout by apavel@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/5dc361e890c3
Backed out 3 changesets for causing failure on test_ThirdPartyModulesPing.js.

Updated Part 1 and 2.

Flags: needinfo?(tkikuchi)
Pushed by abutkovits@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7709195b22a9
Part1. Add a member to ModuleLoadInfo to indicate the status of DLL load.  r=mhowell
https://hg.mozilla.org/integration/autoland/rev/2635f936fdeb
Part2. Add the loadStatus field to the third-party-modules ping.  r=chutten
https://hg.mozilla.org/integration/autoland/rev/172ac9e345fb
Part3. Display a module's loading status on about:support.  r=Gijs,fluent-reviewers
Pushed by ncsoregi@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/e8fb88c455a6
Part1. Add a member to ModuleLoadInfo to indicate the status of DLL load.  r=mhowell
https://hg.mozilla.org/mozilla-central/rev/9dc6d54ed4eb
Part2. Add the loadStatus field to the third-party-modules ping.  r=chutten
https://hg.mozilla.org/mozilla-central/rev/fe3a3c7c5032
Part3. Display a module's loading status on about:support.  r=Gijs,fluent-reviewers

Comment 13 shows each change twice because technically, the backout got reverted on central to prevent merge conflicts.

Regressions: 1688387
Regressions: 1702717
You need to log in before you can comment on or make changes to this bug.