Closed Bug 1686286 Opened 11 months ago Closed 8 months ago

Investigate better Windows 10 setting default browser

Categories

(Firefox :: Shell Integration, task)

task

Tracking

()

RESOLVED DUPLICATE of bug 1703578

People

(Reporter: Mardak, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

When installing Opera 73 on Windows 10, the installer seems to automatically do user actions such as open "Default apps" settings window -> open drop down for Web browser -> select Opera -> close window

mhowell, do you know how this happens and if Firefox has any existing code that could be modified to work on Windows 10 better than just opening the Default apps window?

Flags: needinfo?(mhowell)
Summary: Investigate better Windows 10 setting default and pinning to taskbar → Investigate better Windows 10 setting default browser

I don't know how they're automatically executing user actions like that, no. We do know how to open the right window and even focus the correct setting, so we could do the rest from there by cheating and just simulating the input events, but I don't know if they have something more robust (my guess is that they don't, or I think it would look quite different when it's running), and the fact that I described that technique as cheating kind of tells you how I feel about it. I think it's been made very clear by Microsoft that the default app settings belong to the user, and they're not going to go back to providing a stable way to change them programmatically. You could argue that we are also not taking these kinds of actions except on the user's instructions, but the OS has no way to know that, and taking our word for it is not something they're going to do. I think we're doing the best we can right now, and I don't see that changing any time soon.

Component: Messaging System → Shell Integration
Flags: needinfo?(mhowell)

The approach Opera does indeed isn't robust. From some quick testing, if the system apps screen is already open with focus somewhere, it seems to break sometimes. One time it seemed to be waiting for some state and only after I manually opened the dropdown did it automatically select Opera.

From playing around with keyboard commands and watching this attached video, it seems to be focusing the "Web browser" option, pressing <enter> to open the dropdown, pressing <tab> multiple times until Opera is selected.

UI Automation would be a bit more robust.
But I agree with Howell in general. This restriction is not what we should circumvent, IMO

Blocks: 1637357
Blocks: 1694259
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1703578
You need to log in before you can comment on or make changes to this bug.