Closed Bug 1686956 Opened 4 years ago Closed 2 months ago

ReCaptcha does not work in Firefox

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

Firefox 84
defect

Tracking

()

RESOLVED DUPLICATE of bug 1894735

People

(Reporter: spam, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:84.0) Gecko/20100101 Firefox/84.0

Steps to reproduce:

Try to log in in a site that is using ReCaptcha

Actual results:

the ReCaptcha widget does not appear at all

Expected results:

It should work, like Brave browser that shows it despite having adblocks enabled and third-party cookies disabled.
Please do not close it as duplicated, cause pretending this problem doesn't exist would only drive more users away from Firefox.

Hi, please provide clear steps to reproduce, such as a link to a site that is using ReCaptcha, otherwise we all have to guess if we discuss the same problems. :)

Flags: needinfo?(spam)

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Privacy: Anti-Tracking
Product: Firefox → Core

(In reply to Andre Klapper from comment #1)

Hi, please provide clear steps to reproduce, such as a link to a site that is using ReCaptcha, otherwise we all have to guess if we discuss the same problems. :)

Hello, there are countless examples, forums are full of people complaining that reCAPTCHA never works with Firefox. I believe it's nowadays a common knowledge. Anyway, will post just the last of countless examples:

https://stackoverflow.com/nocaptcha?s=256712c9-236b-4b09-a910-8f9ebfc6a85c

see also screenshot in attachment.

Flags: needinfo?(spam)
Attached image Selection_025.png

Please note that same link works without problems in Brave on same computer with same everything (OS, internet connection, etc etc).

I cannot reproduce this issue using a new profile. I am wondering if this issue is because of certain settings.

Would you be able to test if reCAPTCHA appears when disabling ETP (By clicking the shield icon you can do this)? Thanks.

Severity: -- → S3
Flags: needinfo?(spam)
Priority: -- → P3

Already tried it disabling all TP settings, allowing third party cookies, etc etc, before giving up to submit the bug, no luck.
This does not work not only for me but for a lot of people, just search "reCAPCHA firefox" on Google... I have no idea what your telemetry reports to you, but the problem seems to be almost ubiquitous, like the one with Google Maps (another Google service), but that is another story...

Flags: needinfo?(spam)

Thanks for your reply,

It looks to me that it doesn't relate to AntiTracking given that this issue is still present with disabling TP according to comment 6.

Nihanth, could this be DOH related?

Flags: needinfo?(nhnt11)

I can't reproduce this with DoH turned on - both mode 2 (fallback) and mode 3 (no fallback).

I also have ETP set to default settings. No idea what's going on here, I think we need more information to identify a consistent testcase.

Flags: needinfo?(nhnt11)

(In reply to Anselmo Canfora from comment #6)

just search "reCAPCHA firefox" on Google...

For what it's worth - I Googled this. There are several scattered reports over the last 4 years, but not a single one on the first two pages of search results suggests that this is completely broken - they are mostly about requiring more challenges (which admittedly is not ideal).

There was one report on a support forum about it not working but was resolved by clearing cookies and cache. I also saw another report from a user who claimed that their issue was fixed after an OS update.

A consistently reproducible test-case would be very helpful.

I have the same problem in Firefox 93.0 x64, Windows 10 21H1, since the beginning of October (approx.). Sometimes reCaptcha does not load at all, sometimes I get the message from the screenshot attached above. Most times I just cannot check the reCaptcha checkbox, the loading animation is there forever. It even does not work with the invisible reCaptcha (I do not get any error message then, the form just cannot be submitted).

It also does not work with all extensions disabled. I tested it on two different PCs in two completely different network environments. But all my software and the configuration of FF is the same.

I found out that when opening the developer sidebar via F12 and by checking the "disable cache" checkbox under "network analysis", it works fine everytime. In the Chrome browser it also works fine. So maybe it's a cache problem?

By googling I just found this thread, maybe it's related: https://wordpress.org/support/topic/recaptcha-not-working-properly-in-firefox-if-any-cachedisk-or-memory-enabled/

Now it works again since 2 or 3 days and the user from the linked topic in the Wordpress forum (see my last post) also says that it works again. It seems to work since the last Firefox update to version 94 (released 2021-11-02). And according to the Firefox Release Calendar version 93 was released at the beginning of October, which was the start of my problems. So I guess there was something wrong in version 93.

See Also: → 1744241

Hi, Alice. I believe this old issue should be closed now that there's a new ongoing investigation about the same problem (Bug 1894590).

Flags: needinfo?(alice0775)
Depends on: 1894590
Flags: needinfo?(alice0775)
No longer depends on: 1894590
Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Duplicate of bug: 1894735
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: