Closed Bug 1687681 Opened 8 months ago Closed 1 month ago

[FR][ebay.fr] Expiry date autofill incorrect format

Categories

(Toolkit :: Form Autofill, defect, P2)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
93 Branch
Tracking Status
firefox84 --- disabled
firefox85 --- disabled
firefox86 --- disabled
firefox93 --- verified

People

(Reporter: alin.ilea, Assigned: tgiles)

References

(Blocks 1 open bug, )

Details

Attachments

(3 files)

Attached video 2021-01-20_11h55_38.mp4

Affected Versions:

All latest Firefox versions using force enable (Nightly 86, Beta RC 85.0, Release 84.0.2)

Tested on:

Windows 10 x64

Prerequisites:

browser.search.region FR
extensions.formautofill.supportedCountries FR
download latest Firefox Nightly with region locale (switch extensions.formautofill.available to "on" for testing non-Nightly builds)

Steps to Reproduce:

  1. Launch Firefox
  2. Go to and reach the payment form for ebay.fr
  3. Using autofill feature, select 1 saved CC entry

Expected Results:

Expiry Date should be displayed accordingly like when the user hover over the date from the autofill drop-down.

Actual Results:

Expiry Date incorrect format.

Notes:

Severity: S4 since the issue seems to be ebay.fr specific. It is not reproducible on ebay.com or ebay.ca
Reproducible on Chrome?: No
Regression-range: reproducible on all latest versions, this site was never tested before, can look for regression-range if need be.

Summary: [ebay.fr] Expiry date autofill incorrect format → [FR][ebay.fr] Expiry date autofill incorrect format
Priority: -- → P2
See Also: → 1687679

The issue appears to be because of the placeholder text used, "MM / AA". Our current expiry date transformer does not handle "AA", only "YY"/"YYYY". I wonder what other locale specific placeholders are used for expiration year...

Assignee: nobody → tgiles
Status: NEW → ASSIGNED

Minimum example of the placeholder (MM/AA) not being used to determine the expiry date format.

Duplicate of this bug: 1688613
Duplicate of this bug: 1688615

Our previous regex did not parse "AAAA" or "AA" so I've added this to the transformation regex.
For the year first regex, I added a separate regex because trying to bolt on the missing "AA" caused the resulting parsed result to drop characters for other locales ("yyyy" became "yyy" and the same with "aaaa").

Attachment #9232509 - Attachment description: Bug 1687681: Add France specific CC expiry date transformation. r=dimi,sfoster → WIP: Bug 1687681: Add France specific CC expiry date transformation. r=dimi,sfoster
Attachment #9232509 - Attachment description: WIP: Bug 1687681: Add France specific CC expiry date transformation. r=dimi,sfoster → Bug 1687681: Add France specific CC expiry date transformation. r=dimi,sfoster
Attachment #9232509 - Attachment description: Bug 1687681: Add France specific CC expiry date transformation. r=dimi,sfoster → WIP: Bug 1687681: Add France specific CC expiry date transformation. r=dimi,sfoster
Attachment #9232509 - Attachment description: WIP: Bug 1687681: Add France specific CC expiry date transformation. r=dimi,sfoster → Bug 1687681: Add France specific CC expiry date transformation. r=dimi,sfoster
Pushed by tgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8077cd932f28
Add France specific CC expiry date transformation. r=dimi,sfoster
Backout by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/46b6b85d8130
Backed out changeset 8077cd932f28 for causing build bustages. CLOSED TREE

Duplicate tests from the rebase onto central got me, new patch should land this time.

Flags: needinfo?(tgiles)
Pushed by tgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f8cfbf461c7c
Add France specific CC expiry date transformation. r=dimi,sfoster
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

Verified - Fixed in latest Nightly 93.0a1 (20210820095755) using windows 10 and ebay.fr. The expiry date format is correctly displayed.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.