Closed Bug 1688049 Opened 3 months ago Closed 2 months ago

Import Password from CSV dialog has wrong focus

Categories

(Firefox :: about:logins, defect, P3)

Firefox 86
Desktop
Unspecified
defect

Tracking

()

VERIFIED FIXED
87 Branch
Tracking Status
firefox85 --- unaffected
firefox86 --- wontfix
firefox87 --- verified
firefox88 --- verified

People

(Reporter: petcuandrei, Assigned: petcuandrei)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:86.0) Gecko/20100101 Firefox/86.0

Steps to reproduce:

I imported a CSV file with an error (after that I also imported a file with an error).
After the dialog is shown, I press enter.

Actual results:

Nothing.

Expected results:

The error dialog should have had focus on the "learn more" link. The no-error dialog should have had the focus on the "done" button. Enter should have acted as a click on the focused element.

Blocks: 1303176

r=jaws

Depends on D102639

Assignee: nobody → petcuandrei
Status: NEW → ASSIGNED

Setting component to match the issue area.
I can't confirm this issue since I'm not sure what kind of CSV files I should be importing and how, but I can see that you created this issue and assigned it to yourself.

I assume you're already expecting a review. Hopefully, you'll get one soon.
If you think a testing confirmation is needed, please give a little more details.

Thank you for your contribution!

Component: Untriaged → DOM: UI Events & Focus Handling
Flags: needinfo?(petcuandrei)
Product: Firefox → Core
Hardware: Unspecified → Desktop

I made a patch already. I think Sam should know more about the testing need.

Flags: needinfo?(petcuandrei) → needinfo?(sfoster)
Severity: -- → S3
Component: DOM: UI Events & Focus Handling → about:logins
Priority: -- → P3
Product: Core → Firefox

Moving this back to about:logins, since this is a specific issue of how we're handling focus in the about:logins component and not in the DOM in general

Flags: qe-verify-

:danibodea, For testing the success case with the import summary dialog, We support importing CSV files produced by export from the popular password managers and browser (including our own logins export to CSV from e.g. another firefox profile). So, for example you could:

  • In about:logins, create a valid login.
  • Open the "..." menu and select "Export logins.." and save the resulting file
  • In the menu, select "Remove all logins" and confirm
  • Using the keyboard, open the menu, select "Import logins" and select the file you saved earlier from the Export step

ER:

  • The "Import Complete" dialog should open. Focus should already be on the "Done" button, so that passing "Enter"/"Return" on the keyboard should dismiss the dialog

We can probably write an automated test for this, but it might be useful to confirm manually.

Flags: needinfo?(sfoster)
Attachment #9198924 - Attachment description: Bug 1688049 Import Password from CSV dialog has wrong focus → Bug 1688049 - Fix wrong focused elements on Import Password from CSV dialogs
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ea5a171f7446
Fix wrong focused elements on Import Password from CSV dialogs r=tgiles
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch

I have verified this issue using the latest Firefox Nightly 88.0a1 (Build ID: 20210303215027) and Firefox Beta 87.0b5 (Build ID: 20210302185821) on Windows 10 x64, Ubuntu 20.04 and macOS 11.1.

  • After importing logins from a CSV file, the “Import Complete” modal has the “Done” button focused and if pressing the “Enter” key the modal is dismissed.
  • Also, if the “Import Error” modal is triggered, the “Learn more” link is focused and if pressing the “Enter” key the SUMO page is opened in a new tab.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.