Closed Bug 1688415 Opened 1 year ago Closed 3 months ago

Remove NPAPI support in SeaMonkey

Categories

(SeaMonkey :: General, enhancement)

enhancement

Tracking

(seamonkey2.53? affected)

RESOLVED FIXED
seamonkey 2.96
Tracking Status
seamonkey2.53 ? affected

People

(Reporter: frg, Assigned: frg)

References

Details

(Whiteboard: SM2.53.7)

Attachments

(3 files)

Flash was the last supported plugin using NPAPI. Effective January 12th it is dead. We still need plugin support for possible future EME support but some code in preferences and other places can be removed.

Summary: Remove NPAPI support in SeaMonkey. → Remove NPAPI support in SeaMonkey

Kills some of the prefs. I am unsure about some of the notification code right now but can wait.
We don't have EME support so I can't tell if click to ply or the default state is used for the EME stuff. So I kept it.

Attachment #9198836 - Flags: feedback?(iann_bugzilla)

Minimum patch for disabling the Flash plugin in our release branches.

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: Hacked flash can be enabled.
Testing completed (on m-c, etc.): 2.53.7
Risk to taking this patch (and alternatives if risky): tricial
String changes made by this patch: --

Attachment #9198837 - Flags: review?(iann_bugzilla)
Attachment #9198837 - Flags: approval-comm-release?
Attachment #9198837 - Flags: approval-comm-esr60?

Comment on attachment 9198837 [details] [diff] [review]
1688415-killflash-2537.patch [checked in comment 5 Target 2.53.7]

[Triage Comment]
Seems to do what it says on the tin
r/a=me

Attachment #9198837 - Flags: review?(iann_bugzilla)
Attachment #9198837 - Flags: review+
Attachment #9198837 - Flags: approval-comm-release?
Attachment #9198837 - Flags: approval-comm-release+
Attachment #9198837 - Flags: approval-comm-esr60?
Attachment #9198837 - Flags: approval-comm-esr60+

Comment on attachment 9198836 [details] [diff] [review]
1688415-killflash-cc.2537.patch

Only thing I see that has been missed is removing:
https://searchfox.org/comm-esr60/source/suite/mailnews/jar.mn#15

As you say the notification bar changes can be in a follow-up

Attachment #9198836 - Flags: feedback?(iann_bugzilla) → feedback+
Attachment #9198837 - Attachment description: 1688415-killflash-2537.patch → 1688415-killflash-2537.patch [checked in comment 5 Target 2.53.7]

Patch has baked for some time now in the pre build but I added some more removals and set a few defaults for fallback. Not sure if the fallbacks are still valid in todays web world. Should be all html5 anyway but if not this should help.

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: useless gunk in the ui
Testing completed (on m-c, etc.): 2.53.12b1 pre
Risk to taking this patch (and alternatives if risky): NPAPI and Flash are already dead.
String changes made by this patch: Various removals.

Attachment #9261443 - Flags: review?(iannbugzilla)
Attachment #9261443 - Flags: approval-comm-release?
Attachment #9261443 - Flags: approval-comm-esr60?

Comment on attachment 9261443 [details] [diff] [review]
1688415-killflash-cc-25312.patch [checked in comment 8 Target 2.53.12]

[Triage Comment]
LGTM r/a=me

Attachment #9261443 - Flags: review?(iannbugzilla)
Attachment #9261443 - Flags: review+
Attachment #9261443 - Flags: approval-comm-release?
Attachment #9261443 - Flags: approval-comm-release+
Attachment #9261443 - Flags: approval-comm-esr60?
Attachment #9261443 - Flags: approval-comm-esr60+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/da214111fd19
Remove preferences for NPAPI. r=IanN

Lets close. We might need follow-ups later for preferences and notification removal but this can wait.

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.96
Attachment #9261443 - Attachment description: 1688415-killflash-cc-25312.patch → 1688415-killflash-cc-25312.patch [checked in comment 8 Target 2.53.12]
Blocks: 1758289
Blocks: 1762733
You need to log in before you can comment on or make changes to this bug.