Closed Bug 1762733 Opened 2 months ago Closed 2 months ago

Remove obsolete plugin code from SeaMonkey

Categories

(SeaMonkey :: General, task)

Tracking

(seamonkey2.53? affected)

RESOLVED FIXED
Tracking Status
seamonkey2.53 ? affected

People

(Reporter: frg, Assigned: frg)

References

Details

(Whiteboard: SM2.53.12)

Attachments

(6 files, 1 obsolete file)

Clean out remaining NPAPI plugin code from suite.

We need to port bits and pieces from various bugs for this. Most notable:

Bug 1675349 Disable plugin support
Bug 1682030 Mass removal of NPAPI plugin code
Bug 1706452 Package libmozgtk.so for Linux builds

With all the bugs it touches this was like peeling an apple so sorry for the one big patch. But 90% is trivial.
The only code worth looking at is in suite/components/bindings/notification.xml. But even this is basically removal only and I tested extensively. There is still some plugin-crashed code in which will never be executed. In the unlikely event that we ever support EME we need to fix this up. I think lets leave it in for now so that we know what to touch.
suite/components/pref/content/pref-applications.js is the other file worth a look but also tested. In the unlikely event that someone has a handler set for a plugin there is fallback code in with kActionUsePlugin defined locally. Basically the same as in Firefox.

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: Much dead code
Testing completed (on m-c, etc.): 2.53.12b1 pre
Risk to taking this patch (and alternatives if risky):
String changes made by this patch: various removals and 2 new variables accounting for the plugin prefs removal.

Attachment #9270565 - Flags: review?(iannbugzilla)
Attachment #9270565 - Flags: approval-comm-release?
Attachment #9270565 - Flags: approval-comm-esr60?

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: broken tests
Testing completed (on m-c, etc.): already broken
Risk to taking this patch (and alternatives if risky): test only.
String changes made by this patch: --

Attachment #9270566 - Flags: review?(iannbugzilla)
Attachment #9270566 - Flags: approval-comm-release?
Attachment #9270566 - Flags: approval-comm-esr60?

This is for our mozilla release branch only. Removal of the flash cassifier lists which are only good as a virtual doorstopper at this point in time. Tested with both SeaMonkey and a Firefox built from our 2.53 branch.

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: Useless list fetches.
Testing completed (on m-c, etc.): 2.53.12b1 pre / 56.12
Risk to taking this patch (and alternatives if risky): cleanup code.
String changes made by this patch: --

Attachment #9270567 - Flags: review?(iannbugzilla)
Attachment #9270567 - Flags: approval-comm-release?
Attachment #9270567 - Flags: approval-comm-esr60?

Again stuff for our mozilla release branch only.
Bits and pieces removed from various bugs we will never port because they touch removed code but some of this is still in central like the flashclassification. As far as I see it this is dead as are most of the remaining dom.ipc.plugins.* preferences:
https://searchfox.org/mozilla-central/search?q=flashclassi&path=&case=false&regexp=false

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined:
Testing completed (on m-c, etc.):
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:

Attachment #9270568 - Flags: review?(iannbugzilla)
Attachment #9270568 - Flags: approval-comm-release?
Attachment #9270568 - Flags: approval-comm-esr60?

Trivial packaging fix porting needed part of bug 1706452 "Package libmozgtk.so for Linux builds" r/a=me

Attachment #9270569 - Flags: review+
Attachment #9270569 - Flags: approval-comm-release+
Attachment #9270569 - Flags: approval-comm-esr60+

Stumbled over some mail code. Will never be used by us but r/a=me for our 2.53 and 2.57 branches only to make the cleanup complete.

Attachment #9270570 - Flags: review+
Attachment #9270570 - Flags: approval-comm-release+
Attachment #9270570 - Flags: approval-comm-esr60+

Comment on attachment 9270565 [details] [diff] [review]
1762733-plugincleanup-25312.patch

[Triage Comment]
Shouldn't plugin.png also be removed from both themes?
r/a=me with that addressed

Attachment #9270565 - Flags: review?(iannbugzilla)
Attachment #9270565 - Flags: review+
Attachment #9270565 - Flags: approval-comm-release?
Attachment #9270565 - Flags: approval-comm-release+
Attachment #9270565 - Flags: approval-comm-esr60?
Attachment #9270565 - Flags: approval-comm-esr60+

Comment on attachment 9270566 [details] [diff] [review]
1762733-plugincleanup-tests-25312.patch

[Triage Comment]
LGTM r/a=me

Attachment #9270566 - Flags: review?(iannbugzilla)
Attachment #9270566 - Flags: review+
Attachment #9270566 - Flags: approval-comm-release?
Attachment #9270566 - Flags: approval-comm-release+
Attachment #9270566 - Flags: approval-comm-esr60?
Attachment #9270566 - Flags: approval-comm-esr60+

Comment on attachment 9270567 [details] [diff] [review]
1762733-removeflashblocking-25312.patch

[Triage Comment]
LGTM r/a=me

Attachment #9270567 - Flags: review?(iannbugzilla)
Attachment #9270567 - Flags: review+
Attachment #9270567 - Flags: approval-comm-release?
Attachment #9270567 - Flags: approval-comm-release+
Attachment #9270567 - Flags: approval-comm-esr60?
Attachment #9270567 - Flags: approval-comm-esr60+

Comment on attachment 9270568 [details] [diff] [review]
1762733-removepluginprefs-25312.patch

[Triage Comment]
LGTM r/a=me

Attachment #9270568 - Flags: review?(iannbugzilla)
Attachment #9270568 - Flags: review+
Attachment #9270568 - Flags: approval-comm-release?
Attachment #9270568 - Flags: approval-comm-release+
Attachment #9270568 - Flags: approval-comm-esr60?
Attachment #9270568 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/eb6738538ba0
Wipe defunct plugin tests. r=IanN
https://hg.mozilla.org/comm-central/rev/3d443503387f
Remove obsolete plugin code. r=IanN
https://hg.mozilla.org/comm-central/rev/f50ef94b27fc
Port bug 1706452: Package libmozgtk.so for Linux builds. r=me

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

[Triage Comment]
Shouldn't plugin.png also be removed from both themes?
r/a=me with that addressed

Yes not used. Removed in checkin.

Looks like some of the mail sutff was still in central and ended up just being removed now. So just some stuff left for our branch removed earlier which I didn't track where.

Not really used in our code so as before r/a=me

Attachment #9270570 - Attachment is obsolete: true
Attachment #9271064 - Flags: review+
Attachment #9271064 - Flags: approval-comm-release+
Attachment #9271064 - Flags: approval-comm-esr60+
You need to log in before you can comment on or make changes to this bug.